[D2D]Title bar and window border are not repainted properly, if menu popup/panel and titlebar/border overlapped each other

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 452917 [details]
screen shot

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100621 Minefield/3.7a6pre ID:20100621053039
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100621 Minefield/3.7a6pre ID:20100621053039

Title bar and window border are not repainted properly, if menu popup/panel and title bar/toolbar  overlapped each other.

Title bar and window border are not only own window but also the other window application.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile + D2D + Window Classic Style
2. Popup menu (or Panel such as Edit Bookmarks) so that the popup overlapped the title bar of Firefox own and/or the other application
3. Hide popup

Actual Results:
 Repainting fails.

Expected Results:
 Repainting should be performed properly.
(Reporter)

Updated

7 years ago
Blocks: 549116
Strange, that's a windows problem it almost appears. What's that window behind FF?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Strange, that's a windows problem it almost appears. What's that window behind
> FF?
It happens on not only Explorer, but also IE8, Firefox3.5.9 and any other application.
(Reporter)

Updated

7 years ago
Summary: [D2D]Title bar and window border are not repainted properly, if menu popup/panel and titlebar/toolbar overlapped each other → [D2D]Title bar and window border are not repainted properly, if menu popup/panel and titlebar/border overlapped each other
(Reporter)

Comment 3

7 years ago
Now, the rendering issue does not happen.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100818 Minefield/4.0b5pre ID:20100818112603

So, I change status to RESOLVED WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(In reply to comment #3)
> Now, the rendering issue does not happen.
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100818
> Minefield/4.0b5pre ID:20100818112603
> 
> So, I change status to RESOLVED WORKSFORME.

This was caused by D2D doing something wrong with the Classic theme and was fixed a while ago.
You need to log in before you can comment on or make changes to this bug.