Closed Bug 573779 Opened 10 years ago Closed 7 years ago

Intermittent failure in browser_dragdrop.js | application timed out after 330 seconds with no output

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows Server 2003
defect
Not set

Tracking

()

RESOLVED WORKSFORME
mozilla2.0b7

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1277226959.1277228016.15872.gz
WINNT 5.2 mozilla-central opt test mochitest-other on 2010/06/22 10:15:59
s: win32-slave22

TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Running test 5
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Drag should be accepted
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Console message: LOG addons.xpi: Download started for http://example.com/browser/toolkit/mozapps/extensions/test/browser/addons/browser_dragdrop1.xpi to file C:\DOCUME~1\cltbld\LOCALS~1\Temp\tmp-fjg.xpi
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Console message: LOG addons.xpi: Download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/addons/browser_dragdrop1.xpi completed.
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Should have opened the correct window
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Should be the right number of installs
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Should have seen http://example.com/browser/toolkit/mozapps/extensions/test/browser/addons/browser_dragdrop1.xpi in the list
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Should have seen file:///e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-mochitest-other/build/mochitest/browser/toolkit/mozapps/extensions/test/browser/addons/browser_dragdrop2.xpi in the list
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Console message: LOG addons.xpi: Cancelling download of file:///e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-mochitest-other/build/mochitest/browser/toolkit/mozapps/extensions/test/browser/addons/browser_dragdrop2.xpi
TEST-INFO | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/addons/browser_dragdrop1.xpi
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | Found 1 unexpected tab(s) at the end of test run
TEST-INFO | checking window state
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | already focused
TEST-PASS | chrome://mochikit/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object XPCNativeWrapper [object Window]]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object XPCNativeWrapper [object Window]]) about:blank docshell visible: true
This log kind of irritates me, we should log what tabs were left to help figure this out.
Attachment #453111 - Flags: review?(gavin.sharp)
Attachment #453111 - Flags: review?(gavin.sharp) → review+
Comment on attachment 453111 [details] [diff] [review]
Log which tabs were left at the end of the test [checked in]

I'd probably add a |let lastTab = | just for clarity.
Comment on attachment 453111 [details] [diff] [review]
Log which tabs were left at the end of the test [checked in]

Checked this in: http://hg.mozilla.org/mozilla-central/rev/21c3e7e24033
Attachment #453111 - Attachment description: Log which tabs were left at the end of the test → Log which tabs were left at the end of the test [checked in]
The last three comments were actually a separate problem.
Summary: Intermittent failure in browser_dragdrop.js | Found 1 unexpected tab(s) at the end of test run → Intermittent failure in browser_dragdrop.js | Timed out | Found 1 unexpected tab(s) at the end of test run
Duplicate of this bug: 576390
I'm fairly confident that bug 608210 has fixed this.
Assignee: nobody → robert.bugzilla
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 608210
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
(In reply to comment #17)
> I'm fairly confident that bug 608210 has fixed this.

Hard to tell because there hasn't been reported a failure since July 15h. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
bah... this one appears to be extremely intermittent and I wouldn't be surprised if the Windows failures were fixed by bug 608210 and that the Linux failures are due to a focus issue.
Assignee: robert.bugzilla → nobody
For me, this bug no longer says 1 unexpected tabs at end of run but has a crash instead. Should we change the title?
(In reply to comment #33)
> For me, this bug no longer says 1 unexpected tabs at end of run but has a crash
> instead. Should we change the title?

Yes.
Summary: Intermittent failure in browser_dragdrop.js | Timed out | Found 1 unexpected tab(s) at the end of test run → Intermittent failure in browser_dragdrop.js | application timed out after 330 seconds with no output
For the record, I don't believe that's an actual crash.  I think that's the test harness sending SIGABRT after the maximum timeout.
Blocks: 778131
Status: REOPENED → RESOLVED
Closed: 9 years ago7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.