Add option to pin tab from tab's contextual menu

RESOLVED FIXED in Firefox 4.0b2

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Terepin, Assigned: johnath)

Tracking

unspecified
Firefox 4.0b2
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100623 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100623 Minefield/3.7a6pre

Currently there is no way how can ordinary user pin tabs. The best approach is to add "Pin tab" into tab's contextual menu.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 563730

Updated

8 years ago
Component: Disability Access → Tabbed Browser
QA Contact: disability.access → tabbed.browser

Comment 1

8 years ago
Ugh, the original title just made my head hurt.
Summary: Add option to pin tab into tab's contextual menu → Add option to pin tab from tab's contextual menu
(Reporter)

Comment 2

8 years ago
Sorry, my English isn't perfect. :)
will likely want the string to reference app tabs instead of pinning.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

8 years ago
Created attachment 455781 [details] [diff] [review]
Add context menu items

Is it naive to imagine something this simple might do the job? It's what I've been using locally.

It uses "Convert to App Tab" and "Convert to Normal Tab" - I can readily believe we have better strings to use than those. I'd love to either get some strings quickly, or push "good strings" out to a follow up bug, though -- I'd like to get people using the feature and they need a UI to do so.
Attachment #455781 - Flags: ui-review?(faaborg)
Attachment #455781 - Flags: review?(dao)

Updated

8 years ago
Attachment #455781 - Flags: review?(dao) → review+
(Assignee)

Comment 5

8 years ago
Created attachment 456079 [details] [diff] [review]
"Make into App Tab"/"Make into Normal Tab"

Beltzner gave ui-r for "Make into App Tab", "Make into Normal Tab" with the caveat that we file a blocking follow up to wordsmith. I'll file that momentarily.
Assignee: nobody → johnath
Attachment #455781 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #456079 - Flags: ui-review+
Attachment #455781 - Flags: ui-review?(faaborg)
(Assignee)

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/563e67d69a8a
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Depends on: 577004
(Assignee)

Comment 7

8 years ago
(In reply to comment #5)

> Beltzner gave ui-r for "Make into App Tab", "Make into Normal Tab" with the
> caveat that we file a blocking follow up to wordsmith. I'll file that
> momentarily.

Filed bug 577004 on the wordsmithy.

Comment 8

8 years ago
When changing to an App tab or reverting to a Normal tab the tabstrip moves up or down depending on what you are changing too.  IMO it would be a cleaner look if nothing 'moved' at all.  More polished as they say.

Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100705 Minefield/4.0b2pre - Build ID: 20100705120153

Comment 9

8 years ago
Also the favicons on the tabs (App/Normal) don't line up.  The App tab is a pixel or two above the Navigation bar (by design?).  Changing all tabs to App tabs causes strange results depending whether using small or large icons.  Using large ones the tabs and the Nav bar run together.  Small icons causes the Nav bar to disappear.
(Assignee)

Comment 10

8 years ago
Gary - thanks for the comments, but these are probably more likely to get fixed as followup bugs - one bug per issue is typically the quickest way to get developer attention on things. Can you file those?

Comment 11

8 years ago
I've found more oddities.  Can I just make them all one bug report?
(Assignee)

Comment 12

8 years ago
Closely related things, like multiple small layout issues, can typically be combined since the fix will likely be in the same place for all of them. But functional bustage or misbehaviour should probably be kept separate, since the solution for each one of those might be independent. Does that make sense?

Comment 13

8 years ago
I'm finding so many quirks depending on so many factors like small versus large icons, menu bar shown/hidden.  Drawn titlebar/Windows Titlebar.  If you have an icon on the tabstrip or not.  An add-on of mine doesn't quite work as it should. 

I'll see what I can do but I'm surprised you haven't come across these.

Comment 14

8 years ago
Sorry I'm still posting here but to be honest I am finding so many things screwed up I would be filing bugs on it till the cows come home.  The latest thing is when I restart Fx I get an empty tab instead of the page I left off at.

Comment 15

8 years ago
Resetting my toolbars resolved many of my problems.
Flags: in-litmus?
Target Milestone: --- → Firefox 3.7b2
Jonthat: sorry about the lag with the ui-review on 7/5, for spin off bugs note that Limi is driving this feature from the UX side.
(Assignee)

Comment 17

8 years ago
(In reply to comment #16)
> Jonthat: sorry about the lag with the ui-review on 7/5, for spin off bugs note
> that Limi is driving this feature from the UX side.

No sweat - I'll go ask him in the other bug what text he would like. :)
I would like to ask, is it intended that after restarting(normal close FF and open FF) Firefox with a app tab, the app tab change back into a normal tab?
(Assignee)

Comment 19

8 years ago
(In reply to comment #18)
> I would like to ask, is it intended that after restarting(normal close FF and
> open FF) Firefox with a app tab, the app tab change back into a normal tab?

Nope! But that's bug 575560
There are Litmus test cases for pinning and unpinning an app tab - https://litmus.mozilla.org/show_test.cgi?id=12094 and https://litmus.mozilla.org/show_test.cgi?id=12767. Setting in-litmus+
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.