Windows Search integration just not working

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: peci1, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; cs; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 FirePHP/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; cs; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

Hi, I was looking forward for windows search integration when installing 3.0. But I didn't manage to get the expected result. 
I checked the appropriate option in Options->Advanced, then a UAC black screen appeared, I granted the requested privilege. Then I rebuilt windows search index. No mail appears in any search (even when specifying kind:e-mail).

I repeated all these steps several times with no success.

Reproducible: Always

Steps to Reproduce:
1. Install TB 3.0, enable windows search integration.
2. Search for a term from an email in Windows Explorer.
Actual Results:  
Nothing found.

Expected Results:  
My emails could have been found.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
sid when you'll be available what should we be looking into do diagnoze this properly ?

Comment 2

8 years ago
Martin, do you still see this problem?
Whiteboard: [closeme 2011-05-21]
(Reporter)

Comment 3

8 years ago
Well, I've given it one more try. And it works now :) 

I have my mail/ImapMail folder included in indexed locations, but I don't know if I added it or it was done automatically. 

Now I think it could work the time I posted this bug, too, but it was unclear to me how to search for it.

*I don't have my TB profile folder in the standard location*, I've moved it to another drive. Also, in Start Menu properties, I had checked the option not to search public folders from start menu search (I think it is the default). And that's the cause of my problems, I think. Since my profile folder was't in my user profile, the Start menu search box hadn't found any emails. 

Now I have found that when I do a search and then choose to redo the search in custom location and I select to search in "Indexed locations", the emails are found.

So my solution to find emails even by typing the search string into Start menu search box is the following: Right-click Start menu, select Properties->Start Menu->Customize and for the entry "Search other files and libraries" select the option "Search including public folders". Now it works well ;)

I think TB could check (when enabling Win Search integration) if the TB profile folder is under the Windows user profile, and if it isn't, it should provide the user at least the information that no mail results will appear in the start menu search until he chooses to search public folders, too.

The setting whether to search public folders is located in registry My Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced , key Start_SearchFiles. Value 0 means don't search any files (only programs are searched), value 1 means don't search public folders (that one I had before), and value 2 means search also public folders (the one that works for me).

So my proposal is to check for the value of this registry key, and if the TB profile isn't under the windows user profile, ask the user if he wants to change this configuration to be able to find emails from the start menu search.

And one OT: it would be nice to tell the user his saved mail size will increase (at most twice) when he enables the WDS integration (I've looked into the .wdseml files and they are mostly the complete message bodies, maybe just attachments and some headers are stripped out or something).

Updated

8 years ago
Whiteboard: [closeme 2011-05-21]
We need more STR and figure out why it doesn't work on your config.
Keywords: qawanted
(Reporter)

Comment 5

8 years ago
Ok, here you are. I've installed brand new Windows 7 to try some STR.

I've found out that the setting to search not only public folders isn't the default (though I don't know why could I have changed it). The default is to search including public folders. But that doesn't matter anyways.

1) Install Win7 (or just uninstall TB and delete all its folders on the disk)
2) Install TB, check the option to allow search integration on first run
3) Create an account, then enter Account settings -> Server settings and set Local Folder to a folder not under your windows user profile.
4) Quit TB and move the mail folder to the location you've chosen in step 3)
5) Start TB, let it download your mail
6) Let Windows update the search index (in fact, nothing new to be indexed appears)
7) Press the Start button, type a word from a mail you've received

Expected results: some emails appear in the search results
Current results: no emails are found

What I've found out more. After these steps, re-enabling search integration doesn't help. If I look into Indexing options, only the Mail folder under the current profile is selected to be indexed (and some more default folders). The new mail folder isn't in the indexed locations. After manually adding this new folder to indexed locations, everything works as expected.

Another thing - when I move the whole TB profile outside the windows profile folder, then run TB and re-enable search integration, some folders under the new profile location are added to windows indexed locations - but they are just predefined folders under the new TB profile location, not matters whether they really exist or not.

So, my conclusion. The only problem is when you leave your TB profile at the default location and move your account's mail folder outside windows user profile (and other by-default indexed locations).

And my suggestion. TB should monitor whenever the user moves his mail or profile folder (don't know if it is possible with the profile folder, but the mail folder is set in a dialog window and as a TB setting, which, IMHO, has to be easy to be monitored). If it detects some movement, TB should add the new location to the indexed locations.

Moreover, when enabling search integration, TB should (as stated in my last post) alert the user if his mail or profile folder is outside windows user profile and windows have the setting to not search public folders from start menu.
Thanks for the analysis Martin.

Sid does that sound correct ?
(In reply to Ludovic Hirlimann [:Usul] from comment #6)
> Thanks for the analysis Martin.
> 
> Sid does that sound correct ?

Yes, sounds correct. I don't know if I'm going to have time to fix that, though, since (a) fixing it properly will require a lot of effort, and (b) Microsoft's getting rid of Windows Search integration for desktop applications in Windows 8.

Comment 8

6 years ago
(In reply to Siddharth Agarwal [:sid0] from comment #7)
> (In reply to Ludovic Hirlimann [:Usul] from comment #6)
> > Thanks for the analysis Martin.
> > 
> > Sid does that sound correct ?
> 
> Yes, sounds correct. I don't know if I'm going to have time to fix that,
> though, since (a) fixing it properly will require a lot of effort, and (b)
> Microsoft's getting rid of Windows Search integration for desktop
> applications in Windows 8.

yeah - one doesn't hear much about people using it.
fwiw, only other bug reports are 
bug 567212, bug 552769, bug 567073, bug 430614
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Whiteboard: [wontfix?]
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.