Closed Bug 574952 Opened 11 years ago Closed 11 years ago

Thunderbird 3.1 account list / folder pane slow to scroll on Mac

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
macOS
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wd, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [fixed in "1.9.3 branch" by bug 506814])

Attachments

(2 files)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

The left column of Thunderbird is long enough to require scrolling for me.  Mostly due to a large number of RSS feeds.  With Thunderbird 3.0 and earlier, scrolling this pane was quite speedy.   However, with 3.1, scrolling this pane is jumpy and results in 100% cpu usage.

Steps to reproduce:
1. Subscribe to a number of RSS feeds
2. Slowly scroll the left pane up or down

Actual results:
100% CPU usage.  Jumpy scrolling.

Expected results:
Nominal CPU usage.  Smooth scrolling.
The obvious difference here is that the Thunderbird 3.1 sample has a large number of calls to XRE_GetFileFromPath , while 3.0 only has one.
I don't think this is limited to just RSS feeds.  I have two IMAP accounts, one with 140 folders and a second with 160 folders.  Scrolling on TB 3.1beta1 is painfully slow and laggy.
I suspect this is all fine on the Mozilla trunk because in bug 506814 we started using native paths as the persistent descriptors instead of the mac alias stuff. But for 1.9.2, we're still doing that. What I don't see is that 3.0 behaved any differently from 3.1 in this regard, at least from looking at the code. In any case, I bet this is mac-specific.
Nick, are you on Mac?  If so ...

WD please test Mac nightly build at ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central-trunk/ and report results.
Wayne: Running latest nightly gives smooth scrolling.  Just like 3.0

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100701 Shredder/3.2a1pre
that would be consistent with what I said in #c5
(In reply to comment #6)
> WD please test Mac nightly build at
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central-trunk/ and
> report results.

Ah, yes - that appears to have fixed it.  Both scroll wheel and scroll bar drag are back to their previous speeds. thanks!
WD, Nick, thanks for the feedback.
WD, how many folders?

Bienvenu, 
do you think the patch might acceptable for 1.9.2?  (suspects not)
is this behavior dependent on there being a large number of folders?

(not duping)
fixed (on trunk) by bug 506814
Status: NEW → RESOLVED
Closed: 11 years ago
Depends on: 506814
Resolution: --- → FIXED
Summary: Thunderbird 3.1 account list slow to scroll → Thunderbird 3.1 account list / folder pane slow to scroll on Mac
Whiteboard: fixed by bug 506814
I have about 60 subscribed RSS feeds.
(In reply to comment #10)
> do you think the patch might acceptable for 1.9.2?  (suspects not)
I suspect you suspect correctly.
> is this behavior dependent on there being a large number of folders?
I doubt it, other than the more folders you have, the longer you can scroll, and the slower it can seem.

I can't say I understand this regression completely. Nick, do you have any extensions installed?
british english dictionary 1.19 + enigmail 1.1.2
I also have enigmail installed, however uninstalling it makes no difference with performance.  3.1 has slow scrolling on OSX with no extensions installed.
this still seems to be broken in TB 3.1.1.  Was the fix committed to this version?  The latest nightly works fine.
(In reply to comment #15)
> this still seems to be broken in TB 3.1.1.  Was the fix committed to this
> version?  The latest nightly works fine.

details are in bug 506814. In short no, it's fixed only in gecko 1.9.3. 3.1 is based on gecko 1.9.2.

And whether it will be fixed on 3.1, depends on how severe the impact is on using the UI - minor impact perf issues aren't likely to be accepted for 1.9.2
it's severe enough for me to make 3.1 unusable on a mid-2009 MBP / 2.8Ghz / 8G memory.  Scrolling down through the folder pane is impossibly inaccurate because of the lag.  And if you click to scroll (rather than drag-to-scroll), about 2/3 of the time it registers 2 clicks instead of one (maybe registering mouse-unclick as a separate scrollable event?), and you end up scrolling way too far.
WD, Nick, does this old trunk build resolve the Mac folder pane scroll slowness??
(please test with indexing disabled, and for safety make sure you use a TEST profile)
 ftp://ftp.mozilla.org/pub/thunderbird/nightly/2010/01/2010-01-01-06-comm-central-trunk/

Mike, Joe, Roland, do you also see this slowness on Mac?
Wayne: The version you link to is smooth as silk.
(In reply to comment #19)
> Wayne: The version you link to is smooth as silk.

Thanks. WD
Is the right (message thread) pane is unaffected, correct?

We should ask to get bug 506814 fixed in version 3.2 and perhaps v3.1
(In reply to comment #20)
> Is the right (message thread) pane is unaffected, correct?


Correct.  The message thread is unaffected.
yep, not seeing this problem on 2010-01-01-06-comm-central-trunk.  Scrolling is as quick as usual.  I'm stuck using shredder at the moment, so it would be really good to go back to a stable 3.1 release.
(In reply to comment #18)
> WD, Nick, does this old trunk build resolve the Mac folder pane scroll
> slowness??
> (please test with indexing disabled, and for safety make sure you use a TEST
> profile)
> 
> ftp://ftp.mozilla.org/pub/thunderbird/nightly/2010/01/2010-01-01-06-comm-central-trunk/
> 
> Mike, Joe, Roland, do you also see this slowness on Mac?

I don't see this on my 450MHz G4. Then again, (a) I don't have anywhere near the number of folders & feeds that the OP has, and (b) everything's "slow" anyhow. :)

It does make me wonder, though, if it's x86-specific.
Just a note that this is definitely still not fixed in 3.1.7, though it's fine in Miramar Alpha 1. Would be really nice to have this fix back-ported to 3.1.x, as Thunderbird is almost unusable for me as is.
Just follow up to Gavriel's note, I am on 3.1.10 and the bug still exist in 3.1.X branch.
(In reply to Joe Sewell from comment #23)
> It does make me wonder, though, if it's x86-specific.

if it was related to bug 506814, no. It simply cites "Going through this stuff makes us hit Carbon file URLs and end up super slow."
Whiteboard: fixed by bug 506814 → [fixed in "1.9.3 branch" by bug 506814]
Gavriel, Bart, do you see this in version 5 or newer?  You shouldn't see it any more because of comment 5.

(In reply to Gavriel State from comment #24)
> Just a note that this is definitely still not fixed in 3.1.7, though it's
> fine in Miramar Alpha 1. Would be really nice to have this fix back-ported
> to 3.1.x, as Thunderbird is almost unusable for me as is.

(In reply to Bart Swedrowski from comment #25)
> Just follow up to Gavriel's note, I am on 3.1.10 and the bug still exist in
> 3.1.X branch.
This seems to have regressed with Thunderbird 15.   Perhaps not as bad when I originally filed the bug, but noticeably slower than 14.

Bug is definitely back with Thunderbird 78.

Steps to reproduce:

  1. Have enough stuff in Account pane so that you have to scroll
  2. Scroll the left pane up or down

Actual results:
60-80% CPU usage. Very laggy and Jumpy scrolling.

Expected results:
Nominal CPU usage. Smooth scrolling.

I'm on Mac OS Catalina 10.15.7 (19H2) and Thunderbird 78.4.1 (64-bit).

Same on Thunderbird 78.4.3 (64-bit)
macOS Catalina 10.15.7 (19H2)
MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports)
have at least 8 mailboxes ( 30~ folders + 100 subfolders per mailbox )

(In reply to Nicolas from comment #29)

Bug is definitely back with Thunderbird 78.

Steps to reproduce:

  1. Have enough stuff in Account pane so that you have to scroll
  2. Scroll the left pane up or down

Actual results:
60-80% CPU usage. Very laggy and Jumpy scrolling.

Expected results:
Nominal CPU usage. Smooth scrolling.

I'm on Mac OS Catalina 10.15.7 (19H2) and Thunderbird 78.4.1 (64-bit).

(In reply to Nicolas from comment #29)

Bug is definitely back with Thunderbird 78.

Please file a new bug report and post the bug number here, because your current issue is not at all connected to this old, fixed bug. FWIW, https://mzl.la/2K70a9v lists other current Mac issues.

(In reply to Wayne Mery (:wsmwk) from comment #31)

(In reply to Nicolas from comment #29)

Bug is definitely back with Thunderbird 78.

Please file a new bug report and post the bug number here, because your current issue is not at all connected to this old, fixed bug. FWIW, https://mzl.la/2K70a9v lists other current Mac issues.

Thanks! I think someone already opened this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1677380

added my report.

I wanted to report that it is much better in 84.0b3 (64-bit), but still quite sluggish. The best way to describe it: If you hover the mouse over the message list, and stop over a message, the message gets highlighted almost instantly. If you hover the mouse over the account pane, and stop at a certain folder, you can see the mouse marker move slowly over every folder you hovered over in between and then stop at where your current mouse position is.

For the scrolling it is the same - everything is "delayed".

You need to log in before you can comment on or make changes to this bug.