Closed Bug 575109 Opened 10 years ago Closed 10 years ago

Don't unnecessarily inherit from nsISupports (vtable bloat)

Categories

(Core :: Disability Access APIs, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

The CAccessible objects inherit from nsISupports because do_QueryInterface only accepts an nsISupports parameter. However the new do_QueryObject only requires the declaration of the QueryInterface method. Notes: CAccessibleHyperlink.h has to redeclare QueryInterface otherwise the IUnknown version shadows it; CAccessibleHypertext.h already declares QueryInterface.
Attached patch Proposed patchSplinter Review
Attachment #454383 - Flags: review?(surkov.alexander)
Attachment #454383 - Flags: review?(bolterbugz)
Duplicate of this bug: 380836
Comment on attachment 454383 [details] [diff] [review]
Proposed patch

thank you for fixing this, r=me
Attachment #454383 - Flags: review?(surkov.alexander) → review+
Can I have a try-server build for this please? I'd like to give this a quick run against MSAA/IAccessible2 AT software.
(In reply to comment #4)
> Can I have a try-server build for this please? I'd like to give this a quick
> run against MSAA/IAccessible2 AT software.

It's safe change I'm not sure it's necessary to bother you by testing.
OK, thanks!
Comment on attachment 454383 [details] [diff] [review]
Proposed patch

r=me. I think I like do_QueryObject :)
Attachment #454383 - Flags: review?(bolterbugz) → review+
land on 1.9.3 - http://hg.mozilla.org/mozilla-central/rev/6a5c4b7bcabe
Assignee: nobody → neil
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.