Closed Bug 575166 Opened 14 years ago Closed 14 years ago

Middle clicking Firefox app button should close browser.

Categories

(Firefox :: Shell Integration, defect)

x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: imradyurrad, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre

Alternatively, if you have more than one window open, it should close that window.

Reproducible: Always
Depends on: 513162
Summary: Middle clicking Firefox menu button should close browser. → Middle clicking Firefox app button should close browser.
No longer depends on: 513162
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
I don't think this bug is a dup of bug 574973.
They both function the same. Since the other bug isn't looking like it'll landed, this seems like a better workaround.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
No longer blocks: FirefoxButton
Depends on: FirefoxButton
Depends on: 574973
No longer depends on: FirefoxButton
Yeah... Many doubt double clinking the Firefox Button to close a Window is a good feature. I believe middle clinking Firefox Button is more useable, as users tend to double clink more often than they middle clink.
No longer depends on: 574973
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.