Closed Bug 574973 Opened 14 years ago Closed 14 years ago

New Menu button should act as a close button when double clicked [Windows]

Categories

(Firefox :: Shell Integration, defect)

x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: redsign, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100626 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100626 Minefield/3.7a6pre

I really like it to close my windows by double clicking the small icon on the left side of the titlebar. Now that the menu button is shown there, it should act the exact same way if double clicked. 

Reproducible: Always

Steps to Reproduce:
1. Double click the new menu button
2.
3.
Actual Results:  
Menu is opened and closed immediately.

Expected Results:  
The Firefox window should be closed.
Version: unspecified → Trunk
I believe this should be an option. This feature is actually quite interesting.
Some people tend to double click everything, unfortunately, so I don't think we could have this by default, but perhaps when it is double clicked the first time, a message could appear and give an option to define the future behavior. Either allowing the user to choose that the window should always be closed when double clicking on the button, or just opening the menu normally.
A double click on the Office Button in the Office 2007 applications close the window. But sure, there are people that tend to double click all things.
On the second thought, I think this feature should not be implemented because it is very easy for any one to accidently double clink that button. If implemented this feature must be turn off by default. Users who want this feature must turn it on by themselves.
Blocks: 575166
Many people will want to close windows by double clicking the icon on the top left side. I do this always, even if the icon is invisible (for example in Windows 7 Explorer). And I even often try to do this in Linux/Gnome where this unfornuatley doesn't works.

I propose the following solutions:

- Double clicking it should close Firefox.
Thats probably the easiest solutions, and people who double click everytime will learn fast that this will lose the window. (And anyway, they should have learned already that double clicking the top left icon will close windows, so they shouldn't be too surprosed)

- Move the firefox button to the right and display the standard window icon left to it, so you can doubleclick the left icon and access the context menu of it (to manimize, minimize etc.) as usual.

- The same, but make the classic icon invisible.
> people who double click everytime
> will learn fast that this will lose the window. 

Agreed. I was really wondering if there are many people that closed an office application because of that. If so they are doing one or two times and never again. 

> - Move the firefox button to the right and display the standard window icon
> left to it

That would be too much clutter and would be against the design goals of Fx 4, I think. I would rather disclaim that feature completely than having this.
The double click on the left top corner is  actually defined in the Windows UI Design guidelines.

Should we want to make it more in line with Office 2010, then it's always an option to show a small firefox logo left to the button as suggested in comment 6.

Following Chrome's way is also possible, move the button just one or two pixels to the right and let a double click there function as close, and leave the button behavior unaltered.
Status: UNCONFIRMED → NEW
Ever confirmed: true
No longer blocks: 575166
Attached image Possible options
Mockup of 3 possible solutions.

1. Firefox button acts as window icon so double clicking it closes Firefox
2. Firefox button is moved to the right, empty space acts as window icon like in Windows Explorer
3. Firefox button is moved to the right, show "classic" Firefox icon on the left

I vote for option 2, as I think it looks best and it has the most modern feeling, while you can still access the window icon.
I vote for option 2 as well. 

And want to make an extra comment on the doubleclicking everything will close issue.

Currently when doubleclicked, the menu doesn't show at all. And there are no other doubleclick preventions in other parts of the UI. It is my opinion that not following the platform standards is more prohibitive, than trying to solve a problem that exists in people using their system incorrectly. That's something we'll have to live with as long as there is a clear platform distinction between single and doubleclicks,
As to option 3, it looks more like the Office 2010 look this way. Which might actually be a pro ;)
Right. For example Paint adds buttons to the right of the window icon, too. But for me, that just counts as "most native", so this is no extra pro. :)

But I could live with 3 as well.

Thinking about it, I guess it might be actually a good idea, to use option 3 in Windows XP and option 2 in later Windows versions. Because having an invisible icon might look very stupid with the Luna theme and Windows XP probably wants a more classical design anyway. On the other hand, this may add inconsistency between platforms. Not sure.
I would say option 1 or nothing. Option 2 looks weird and option 3 looks really bad. It's not worth for this kind of feature to have the menu button a bit more on the left so that it is no longer in line with the toolbars below it. Since it seems that option 1 won't get in, I think this can be marked as WONTFIX.
Option 2 look weird, and even if implemented no user will know that this feature exist. 

Option 3 look weird because according to Bug 571785 Firefox Button will shrink into a Firefox icon when Tab are in the title bar. So if user put the Tabs in the title bar when maximized they will see 2 Firefox icon in the most left corner of Firefox. This may confuse users. Confusion due to the UI of Firefox is what should be avoided. 

Option 1 is not a good option either because users may accidentally close Firefox by double clinking Firefox Button without any intention to close Firefox at all. 

I still do not know what option is best for Firefox. Hence this should be marked as WONTFIX unless those who want this feature in, can tell us what they want(which option) and why they want it(reason for choosing that option). 

Please explain clearly, if you believe that this is good for Firefox.
(In reply to comment #14)
> Option 2 look weird, and even if implemented no user will know that this
> feature exist. 

I don't think it will look weird. And this icon exists on every main application window in Windows (with some exceptions), so users should actually be surprised if it doesn't exist. On Windows Explorer, this icon is invisible, too, and while you're right, that users who are new to Windows, probably will not know about this icon, users who use Windows a long time and notoriously (double)click on the top left corner, will have no problem to discover it.

> Option 3 look weird because according to Bug 571785 Firefox Button will shrink
> into a Firefox icon when Tab are in the title bar. 

Not sure about the status of this bug, and I'm against shrinking the button, anyway.

> So if user put the Tabs in
> the title bar when maximized they will see 2 Firefox icon in the most left
> corner of Firefox. This may confuse users. Confusion due to the UI of Firefox
> is what should be avoided. 

Showing two Firefox icons together should be avoided in any case, of course.

> Option 1 is not a good option either because users may accidentally close
> Firefox by double clinking Firefox Button without any intention to close
> Firefox at all. 

Right.

> I still do not know what option is best for Firefox. Hence this should be
> marked as WONTFIX unless those who want this feature in, can tell us what they
> want(which option) and why they want it(reason for choosing that option). 
> 
> Please explain clearly, if you believe that this is good for Firefox.

I want to have a window icon in the top left (Option 2 or 3).
Reasons:
- Some people always double click on the top left icon to close a window. Removing this icon will break their common paths
- Accessibility: Some people may be for example only able to do left mouse clicks easily, want to resize the window via the window menu, aren't able to use the icons on the right, etc. So there may be people who usually access the window menu, to (un)maximize/resize/move windows. While the window menu can always be opened using Alt+Space, removing the icon can brake their common path.

Removing the icon is no major issue for me, I will still use Firefox, but it may get annoying for example for users like me, who close windows by double clicking the icon, and it will make Firefox feel less native, as it removes common window functions.

And if I had to choose between a little space next to the menu button, which doesn't look really bad at all, IMO, and breaking usability, I prefer having the space.
"New Menu button should act as a close button" that is what I suggest here nothing else. Mark this as WONTFIX and make another bug for the other strange suggestions (moving menu button, showing icon beside it) made here. I'm sure they get WONTFIX as well. I hope so at least. :P
FYI: The missing window menu is Bug 574859

The UI team still needs to decide if and how we should display the window icon and if double clicking the menu button should close Firefox.
Many users do not differentiate between single and double clicks, so the effect of this change would be a lot accidental window closures for the most novice users.  The system menu previously accessible through the window icon will still be available through right click and alt-space.  However for left mouse click window closing, user's are going to need to single click the window close icon.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
Just to add a comment why double clicking on the left upper side is good. If you have an extended screen to the right, this is the easiest point to go to. Just move the mouse to upper left and double click to close the window. I know this is a "expert" usage but it is the standard behavior on windows application and should be excepted.

An option which is confirmed on the first usage would be the best from my side.
(In reply to comment #19)
> Many users do not differentiate between single and double clicks, so the effect
> of this change would be a lot accidental window closures

So we are breaking platform standards and behaving differently to any other windows applications because /some/ users (who apparently can not use any ribbons office products either) can not differentiate double/singleclick? 
Why doesn't doubleclicking the Firefox menu "work" then? The menu opens and closes again, how can this be expected behaviour? Firefox also does a pretty good job about keeping sessions trough restarts so is accidently closing windows really that bad?

I really don't get the reasoning behind this.
What's worse, is that double-clicking the actual upper left corner now de-maximizes the window, which is even stranger behaviour. I still don't care tgat double-clicking the firefox button doesn't close the window, but do fix the upper left corner of the screen please.
Too bad, that this won't be fixed.
I'm also one of the people out there, that use doubleclick in the upper left corner for closing windows.
I think many users will find the current reaction weired. Of course it's not a killer argument to not use firefox.

As it won't be fixed in a general release, is there any way to customize the behaviour of a double-click on the firefox button in userChrome.css with #appmenu-button?

@Jesse I fixed that problem with following soluting: make a new file in folder chrome of your firefox profile named userChrome.css and insert following:

#appmenu-button-container {
position: fixed !important;
}

#appmenu-button {
padding: 1px 10px !important;
margin-top: 0 !important;
margin-left: 0px !important;
border: 2px solid !important;
border-top: none !important;
}
I was about to file a bug when I spotted this. Whilst it's slightly frustrating, I get the reasoning behind WONTFIXing so am not going to disagree with that. (I've gotten used to using the window close button now, so mitigates the issue somewhat).

However, given that when Fx4 ships there will no doubt be quite a few people who use double-click on window icon to close and think it's a bug - is it worth sticking something in the relnote or else making sure a knowledgebase item is created for this?
(In reply to comment #19)
> The system menu previously accessible through the window icon will
> still be available through right click

Right-clicking the Firefox button does nothing in RC1.
so the new orange firefox4 menu button (as seen on win7 for example) still doesnt behave like the system-menu/area of normal windows.

this bug is really old and long know by now. still firefox 4 final is still affected.

wontfix is really not appropriate. firefox is supposed to be a normally behaving application even on windows. yet its main gui window doesnt act like one. its completely disregarding like at least 15 years of windows usability experience and behaviour.

:((
I don't feel happy with the current way the button behaves either. The mayority of posters in this bug seems to share this understanding, still the decission was made not to fix it. For me as a new participant of this bug tracker I don't really understand how decission making works here, or who decided that this won't be fixed...
Thanks Michael for the CSS, it works and releases my pain.

I hope there will be a reconsideration about this bug. It's just one small pixel that has to be inserted left to the Firefox Button. This won't kill the UI design principles, imho.
I think this should be fixed as well.  As others have pointed out, the standard behavior is used in virtually every other windows application, including those with the Ribbon interface.  Users do not unduly complain about this behavior in other applications.  I don't see why Firefox should be the only one that is different.  Changing the way this works for the sake of people who don't yet understand how it normally works, at the expense of those who do, seems like it does a disservice to both parties.
Please fix. this as annoyed me so much that i just had to google on this behaviour and create an account here just to tell you to FIX THIS!
I hate that i have to move my mouse all the way to the right when im on the left!
The arrogance surrounding this is staggering, but sadly not new.  So it's perfectly ok for this app to break a longstanding behavior of Windows... why?  Because some users are too clueless to differentiate single and double click? 

No doubt such users exist.  Since when, however are they the driving demographic?  Under that criteria I would submit that "https://" is far too confusing, and should be replaced with a happy face, in green.. while "http://" should be a frowny face in stark red.  

What evidence is this WONTFIX decision being based on?  Were studies done to determine that this is so widespread & significant a problem that it is worth overriding the default behavior in a ~15 year old interface?  I seriously doubt it.  Someone just decided to do it, and got general agreement from a couple of people, so now it's done and the wagons are circled.  

I will say this, though.  You're in good company.  Microsoft is also doing the race-to-the-bottom, killing off interface elements that they feel are "too complicated".
I used windows from 3.1 (circa 1994) to vista (~2008).
Though all those versions of Windows, to close a window, users double-clicked on the upper left corner.

Now, I've to use Windows once again, and I find that FIREFOX behaves differently to ***all*** the other win32 application in the last decade and a half.

The reason is that "some dumb users double click everything".
Tough luck on them. They won't be able to open the Windows start menu either, since double clicking on it results in instant open+close, so I think this would be minor (since they won't be able to get as far as opening firefox).

You *can't* adapt firefox to behave how people-who-don't-know-how-to-click expect it to, and leave people who know how to use compueters behind.

I feel firefox is alien to window since it's ui is managed completely opposite to the rest of the applications. ALL of the other applications I've used in almos 15 years.


On the other hand, you still feel that ok and cancel buttons need to be inverted to fit with the OS, or have "preferences" moved over to "options" instead of "edit".
Anecdotally, I've noticed people who have only used computers for a few years using the double click functionality to close windows.

Notably it's way more convenient for those with a secondary screen to the right of their primary, because in that case the right "close" button looses it's "infinite target"/fitts law advantage.
In Firefox 4, the new menu button was introduced.

Both Windows and most Linux desktop environments have always supported the following:

    ------------------------------------------------------------
    | i                                                   _ O X|
    ------------------------------------------------------------
    |                                                          |

A double-click on the icon on the left closes the window. Perfect for Fitts' law. It means I can just shoot my mouse to the top left, click and have the window close. Even if I didn't aim for it, it's at the top left corner.

Basically, 99% of Windows applications do that. Even Chrome:

    ------------------------------------------------------------
    | / tab1          \/tab2           \/tab3          \  _ O X|
    ------------------------------------------------------------
    |                                                          |

Supports closing with a double-click in the area between tab 1 and the left border. Additionally, Fitts' law applied in the y direction means I can just shoot up and without aiming up or down, close the tab, and if it's the last tab, the whole window.

Now, sure you may say, it's just as easy to hit the X?

It's not. I run a dual-screen setup. As do many many people these days.

    --------------------------------------------------...
    |Firefox |tab1        |tab2       |tab3           ...
    --------------------------------------------------
    |

Now for Firefox.

Double-clicking on the Firefox menu does nothing.

When the only tab left is tab 1, middle-clicking on it does nothing.

It has reduced usability for me so much that I don't use Firefox any more.

You know what is the most shocking revelation about this whole thing?

Internet Explorer 9 does it. Double-clicking in the top left corner - closes the window. Middle-clicking the tab when there's only one tab left? Closes the window.

Internet bleeping Explorer 9 does it, Chrome does it and Firefox just say WONTFIX. This isn't H.264, and Firefox even relented on that one. It's a bleeping basic usability feature almost vital for those on two screens that's been 100% standard for - I don't know - 25ish years. Congratulations, Firefox, this is actually one of the biggest reasons you've lost me and the Google start-page related revenue you may have gotten from me and people I'd have recommended Firefox to otherwise. However, as it stands, it's Chrome for me and many other people I know on dual screens.

Firefox. Use it for Firebug, because it's getting more bloated and the UI sucks more and more.
I created a bugzilla account just to comment on this issue.

As it has been stated multiple times above, forcing dual monitor users to aim for the red x near the boarder of their screens is ridiculous since virtually all other windows allow convenient closing by double clicking in the top left.

This is the single reason I have stopped using Firefox over the past couple years since the change.  I am extremely disappointed.

Is it reasonable to assume that users who have actively chosen to download and install Firefox over its competition can also appreciate the difference between single and double clicking everything on their desktop?
> This is the single reason I have stopped using Firefox over the past couple years since the change.  I am extremely disappointed.

It's not the single reason for me, but between this and a middle-click on the last tab not closing the window, it's a big reason. Firefox basically said "screw Fitts' Law" without thinking about the consequences just to make some nicer chrome.

Well, I've got a nicer Chrome.

I use Firefox only for when I need a different browser that isn't IE. That's it. The only times I'm using Firefox are because I need to use Firefox specifically. Or maybe for cases where I can't be bothered clearing out some cookie and Firefox has literally no cookies of mine, because I don't use it.

The reasons I use Firefox have become almost the same reasons I use IE. Which is to say not at all.

And this problem here contributed greatly to that. And for every one of me here, there's a hundred users out there who were affected by this, didn't comment on this log and just switched to Chrome.
Now that the menu button is gone for good in the new release, can we have some possibility to finally close the current firefox window with a double click in the top left corner (without having to switch to the fully classic design)?
Please add this feature. It's basic in Windows and I think most of the poweruser use it.
The Classic Theme Restorer addon implements the feature starting from version 1.19. It's currently still beta, but you can get it from here:

https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/versions/
(In reply to Daniel R from comment #48)
> The Classic Theme Restorer addon implements the feature starting from
> version 1.19. It's currently still beta, but you can get it from here:
> 
> https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/versions/

Thanks for your tip. Atm i'm using the title bar.
I don't care about whether there's a system menu icon, but jeez, at *least* make it so when you double-click the little area to the left of the leftmost tab, it closes Firefox >.<  If you have more than one tab open, it's going to ask for confirmation anyway.

Firefox is the only non-fullscreen-game application I have that does not close upon a double click there.  Double-clicking the system menu to close a program has worked *since Windows 2.0*, if not 1.0.

So, does Firefox want to continue breaking with almost 30 years of Windows UI standards?
You need to log in before you can comment on or make changes to this bug.