When maximizing window, the menu bar gets pushed down.

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: imradyurrad, Assigned: jimm)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100628 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre

With the latest hourly (28-Jun-2010 04:50)
If you maximize a window the menu bar, navigation bar, etc get pushed down about 4px.

Reproducible: Always
(Reporter)

Updated

8 years ago
Component: General → Theme
Version: unspecified → Trunk
Screenshot please.

Comment 2

8 years ago
Sounds like bug 574821
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> Screenshot please.

Working on one right now. 
You have to have the title bar enabled to see it.
(Reporter)

Updated

8 years ago
Depends on: 574821
(In reply to comment #3)
> (In reply to comment #1)
> You have to have the title bar enabled to see it.

I didn't know it can be disabled in the first place :)
But indeed it seems like bug 574821. But that is by design, this was made because Firefox Menu was cut of when window was maximized.
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #1)
> > You have to have the title bar enabled to see it.
> 
> I didn't know it can be disabled in the first place :)
> But indeed it seems like bug 574821. But that is by design, this was made
> because Firefox Menu was cut of when window was maximized.

Menu bar I meant.

In the description, it's more like 1 or 2px not four.
(Reporter)

Comment 6

8 years ago
Mr. Henky, this happens without the Firefox button.
Created attachment 454507 [details]
However I don't see the problem that you mention
(Reporter)

Comment 8

8 years ago
Created attachment 454511 [details]
problem mentioned
(Reporter)

Comment 9

8 years ago
(In reply to comment #7)
> Created an attachment (id=454507) [details]
> However I don't see the problem that you mention

See attachment.
(Assignee)

Comment 10

8 years ago
(In reply to comment #2)
> Sounds like bug 574821

Definitely that, the css we added there - 

+  /* the new titlebar requires this, or content will be clipped at the top of the screen. */
+  #main-window[sizemode="maximized"] {
+    margin-top: 8px;
+  }
+


Needs to be conditional on the fx button being displayed.
(Assignee)

Comment 11

8 years ago
Created attachment 454758 [details] [diff] [review]
update
Assignee: nobody → jmathies
(Assignee)

Comment 12

8 years ago
Comment on attachment 454758 [details] [diff] [review]
update

This seems to fix it. Basically, if the menubar is 'autohide', set an attrib on main-window that css can pick up on to set the offset at the right time.
Attachment #454758 - Flags: review?(dao)

Updated

8 years ago
Blocks: 574821
No longer depends on: 574821
Comment on attachment 454758 [details] [diff] [review]
update

Why not something like #main-window[sizemode="maximized"][chromemargin] or #main-window[sizemode="maximized"][chromemargin^="0,"]?
QA Contact: general → theme
(Assignee)

Comment 14

8 years ago
Created attachment 454881 [details] [diff] [review]
update
Attachment #454758 - Attachment is obsolete: true
Attachment #454758 - Flags: review?(dao)
(Assignee)

Updated

8 years ago
Attachment #454881 - Attachment is patch: true
(Assignee)

Comment 15

8 years ago
Comment on attachment 454881 [details] [diff] [review]
update

(In reply to comment #13)
> (From update of attachment 454758 [details] [diff] [review])
> Why not something like #main-window[sizemode="maximized"][chromemargin] or
> #main-window[sizemode="maximized"][chromemargin^="0,"]?

tricky, I like the last one. works as expected. Thanks Dao.
Attachment #454881 - Flags: review?(dao)

Updated

8 years ago
Attachment #454881 - Flags: review?(dao) → review+
(Reporter)

Comment 16

8 years ago
Nice. Can this be marked resolved now?
(Assignee)

Comment 17

8 years ago
(In reply to comment #16)
> Nice. Can this be marked resolved now?

Not until I land it on m-c! ;)
(Assignee)

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 18

8 years ago
http://hg.mozilla.org/mozilla-central/rev/626decd30ccb
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.