Menu bar cannot be accessed while in full screen mode

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
minor
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: szupie, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100629 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100629 Minefield/4.0b2pre

In Mac OS X, the menu bar cannot be accessed when Firefox is in full screen mode. Usually, in other Mac applications that support full screen mode, the menu bar drops down when the mouse is moved up to the top of the screen.

Reproducible: Always

Steps to Reproduce:
1. Go in full screen mode (by UI button, cmd+shift+f, or F11)
2. Move mouse to top of screen to make Firefox's chrome appear
Actual Results:  
Only tab bar and toolbars appear. Menu bar stays hidden.

Expected Results:  
Menu bar appears, above the tab bar and toolbars
Not all applications behave that way. iTunes doesn't support it, but VLC does. So I wonder what the HIG says about. Confirming for now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 2

7 years ago
As a point of reference, Google Chrome for Mac also shows the menu bar when in full-screen.

Updated

7 years ago
Duplicate of this bug: 648504

Comment 4

6 years ago
Partially answering to comment #1, the OS X 10.7 Lion features page on Apple's website [1] clearly states what's the expected behavior for full screen apps concerning the menubar: "When an app is full screen, the menu bar is hidden, providing maximum screen space for the app. To access the menu bar, just move the pointer to the top of the screen and the menu bar slides down." (waiting for the 10.7 release due soon to read what the updated HIG states, as I'm not a registered Mac developer, thus I don't have access to it yet).

While this doesn't refer to earlier versions of the OS, most Apple-branded and not apps used to behave that way, including (tested on 10.6, as I no longer have previous versions of the OS installed to test this on) QuickTime, Preview, DVD Player.  iTunes and Keynote don't behave that way for the simple reason that they don't even show the mouse pointer, as far as I can tell.

[1]: http://www.apple.com/macosx/whats-new/features.html#fullscreenapps

Comment 5

6 years ago
A small, perhaps important addition to this:
Viewing a stream on http://www.livestream.com/mojang (he's been deleted at the moment) frequently crashes my Flash Player (newest 10.3 version, sent Adobe a bug report). When it happens in Fullscreen, Firefox goes back to not-fullscreen mode, but the menu bar doesn't come back.

Updated

6 years ago
Duplicate of this bug: 729355

Updated

6 years ago
OS: Mac OS X → All

Comment 7

6 years ago
Please add "by mouse" to the summary, to distinguish it from bug #428981.

Comment 8

6 years ago
Benno Schulenberg, two things: I don't know how!

The other thing is that I mistakenly neglected to include the alt key option in the bug description, but that should be included in this bug.  Indeed, I don't consider the problem fixed unless both ways work.  I'll definitely vote for that bug, but it is related, not a completely different bug.

Comment 9

5 years ago
+1 Firefox 20 on Linux

Comment 10

4 years ago
I would like to work on this bug, Can you please assign me with this?
Is this bug even still valid?
OS: All → Mac OS X

Comment 12

4 years ago
Just checked Firefox v26 running on OS X 10.8.5.  Bug is gone.  Menubar shows in full screen mode when moving cursor to top.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 13

4 years ago
Still occurring for me using 25.0.1 on Linux.

When I go to F11 fullscreen, I can summon the invisible menus using Alt+<key> but cannot see the menus.

Using the cursor keys I can move down the invisible entries and press enter to select one... it's like a lucky dip.

Comment 14

4 years ago
Ah, yes, I see the same behaviour as Andrew B.  Looks like the alt keys work, but the menus are invisible/perhaps obscured behind the active window.  I'd call that still broken.  Who exactly does this work for?  I'm on Win7 with FF26.0
That would be bug 648504. This bug was filed on OS X, which has quite different behavior.

Comment 16

4 years ago
Correct, my mistake.  Please see my comment on bug 729355 , which you've incorrectly marked duplicate (at least under this rationale).
You need to log in before you can comment on or make changes to this bug.