Ratings widget should use average_rating

RESOLVED FIXED in 5.11.4

Status

RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: clouserw, Assigned: clouserw)

Tracking

unspecified
5.11.4

Details

(URL)

(Assignee)

Description

8 years ago
Looks like the ratings widget is using bayesian_rating right now - it should use the average_rating.
Should that happen in listings as well, where we are sorting by bayesian rating?
(Assignee)

Comment 2

8 years ago
The idea is to use the bayesian rating when comparing against other add-ons (eg. search listings) and the average rating when displaying something on the page.

Comment 3

8 years ago
If my memory serves me right, we implemented this functionality to avoid addons being ranked top if they had a single 5 star review.
(Assignee)

Comment 4

8 years ago
Original report:
On 06/30/2010 02:58 AM, Chip Volley wrote:
>   https://addons.mozilla.org/en-US/firefox/addon/161757/
>
> Overall Rating says 4 stars
>
> Both reviews are 5 stars - how is this possible?
(Assignee)

Comment 5

8 years ago
http://github.com/jbalogh/zamboni/commit/1174353341b4ebcf43a4cb791ccc624261cdb3ef

The URL in comment 4 was showing 4 stars, it should show 5 after this goes out.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 573683
(Assignee)

Comment 7

8 years ago
It ate my comment when I duped I guess.  Anyway, you can see this fixed at https://preview.addons.mozilla.org/en-US/thunderbird/addon/58857/
This add-on appears to be still experiencing this bug: https://addons.mozilla.org/en-US/firefox/addon/6584/
I think mine as well: https://addons.mozilla.org/en-US/firefox/addon/7684
They were both 5 stars before this bug appeared.

Were there any changes in the way the star count is generated?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

8 years ago
mysql> select id, averagerating, bayesianrating from addons where id in (6584, 7684);
+------+---------------+----------------+
| id   | averagerating | bayesianrating |
+------+---------------+----------------+
| 6584 | 4.39          |        4.30936 | 
| 7684 | 4.48          |        4.45365 | 
+------+---------------+----------------+
2 rows in set (0.04 sec)


There haven't been any changes to the calculations.  If there is a bug, it's not this one.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 10

8 years ago
As a developer of addons.mozilla.org/en-US/firefox/addon/6584
I can said that it's unfair for addons that have 4.5+ rating than 4.5-
 
I think it's wrong calculations 
because there's no difference between 4.1 and 4.8 (this rating earn much harder rather 4.1) rating for regular users, because they'll see 4 star. 
So you need to implement "half-start"

You can go google ant type for example "buy barebone computer"
and under some payid ads you can see rating. And there're different start 
on 4/6  4/8/ 5/0

Because I don't see any point to make my addon better to earn 4/8 because users will see only 4 stars. And developers who have 4/1+ rating do much less for their addons.

Hope you understood my point. 
Sorry, English isn't my native language :)
(Assignee)

Comment 11

8 years ago
If your addon had a rating of 4.5+, it would be shown with 5 stars.  We already round ratings on the backend before showing the stars.
Assignee: nobody → clouserw

Comment 12

8 years ago
good. Thanks
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.