Last Comment Bug 576100 - Flash windowless embed is not displayed when a CSS transform is applied on a parent node
: Flash windowless embed is not displayed when a CSS transform is applied on a ...
Status: RESOLVED FIXED
fall-out from OOPP, fixed on trunk by...
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://uniboard-misc.s3.amazonaws.com...
Depends on: 644832
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 14:26 PDT by Julien Bachmann
Modified: 2011-06-19 15:42 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
wanted
unaffected


Attachments
test - fail (505 bytes, text/plain)
2011-06-19 13:32 PDT, Luke
lstephenson: review+
Details

Description Julien Bachmann 2010-06-30 14:26:13 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

If you embed a flash player in windowless (wmode = transparent) and apply a -moz-transform on its parent node, the embed disappear. It is normal behaviour for windowed but not for windowless

Reproducible: Always

Steps to Reproduce:
1.Open URL
2.Click on Zoom+ or Zoom-
3.
Actual Results:  
video disappear

Expected Results:  
video is zoomed

a bug was already reported before but it was for windowed embed. Developper told that it was normal behaviour. But now the problem appear for windowless embed. See bug #538989
Comment 1 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2010-06-30 14:49:24 PDT
Between which versions did the problem start happening?  And what operating systems were you testing on?
Comment 2 Julien Bachmann 2010-06-30 23:51:09 PDT
Problem appeared between version 3.6.3 and 3.6.6. I'm not sure exactly when problem appeared but I just tested on 3.6.3 and it is working. I'm pretty sure it was also working on 3.6.5 but I don't have 3.6.5 anymore and I don't know where I can download previous version of firefox. 

I'm testing on Mac OS X 10.6.4
Comment 3 Benjamin Smedberg [:bsmedberg] 2010-07-20 11:39:08 PDT
I cannot reproduce this on OSX10.5 and latest trunk. Perhaps retained-layers fixed it? Can you try today's nightly and report back?
Comment 4 Julien Bachmann 2010-07-20 13:20:15 PDT
I've checked on last version of the trunk "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre" and it is working.
But should this regression should be fixed on the 3.6 branch also?
Comment 5 Benjamin Smedberg [:bsmedberg] 2010-07-20 14:22:54 PDT
At this point, it would be nice, but I'm not sure it's going to make the list of important-enough-to-work-on.
Comment 6 Neil Smith 2010-10-03 11:50:41 PDT
Hi - I'm still able to repro this.

It applies specifically on Mac OSX, not on PC version of Firefox (see below)
Note possible dependency on Flash version indicated.

We'll find a workaround for this currently - our CMS code is autogenerating CSS3 defaults which are being cascaded down to the <object /> element generated by SWFObject.



Affected browser version : Firefox 3.6.10; 
PPC Mac OSX 10.4 (also repro on Intel Mac)

Issue not present : Firefox 3.6.3, PPC Mac OSX 10.4
Issue not present : Adobe Flash player 10,0,45,2

Updated base installs and re-tested :
Issue not present : Firefox 3.6.10, PPC Mac OSX 10.4
Issue present : Adobe Flash player 10,0,45,2 (after update)

So it seems some interaction between the latest public Flash release is more related than the actual browser version. Safari and Chrome are unaffected using the equivalent transform settings.

A suggestion : Perhaps these could just be ignored on <object /> <embed /> if there's an issue with applying the transform safely, rather than actually hiding the content ? I'd prefer graceful degradation to actual failure :-)


Minimal repro code :

<html>
	<head>
		<title>Test flash playback</title>
	</head>
	<body>
		<div style="border: 1px solid red; -moz-transform: scale(1) rotate(0deg) skewX(0deg) skewY(0deg)">
		<object width="639" height="366" type="application/x-shockwave-flash" data="http://www.youtube.com/v/WQUhwcsIY1A?fs=1&amp;hl=en_US">
			<param name="quality" value="high">
			<param name="wmode" value="transparent">
			<param name="allowScriptAccess" value="sameDomain">
			<param name="scale" value="default">
		</object>
		</div>
	</body>
</html>

HTH, Cheers - Neil Smith
MVP Digital Media 2004-2010
http://mvp.support.microsoft.com
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2010-10-07 21:47:33 PDT
What about in the latest Firefox 4 beta?
Comment 8 Neil Smith 2010-10-08 02:13:53 PDT
One of our developers ran this against FF4 beta and confirmed it's not an issue in that version : 

"Mark Cooke to me, Luciana, Team" 3 Oct (5 days ago)
I can confirm that the video widget works in Firefox 4.0b6"

We'd prefer not all users on the interwebs to have to upgrade just yet though :-)

HTH, Cheers - Neil
Comment 9 roeycohen@gmail.com 2011-06-19 01:40:52 PDT
This bug still happens to me in FF 4.0.1

too bad, because chrome and even ie9 are able to set the transformation right.
Comment 10 Luke 2011-06-19 13:32:05 PDT
Created attachment 540346 [details]
test - fail

this is a example of a broken element /w a flash video
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-19 15:42:53 PDT
This is fixed in Firefox 5. It was fixed in bug 644832.

Note You need to log in before you can comment on or make changes to this bug.