Last Comment Bug 644832 - Flash content doesn't render when scale transform is applied to parent element.
: Flash content doesn't render when scale transform is applied to parent element.
Status: RESOLVED FIXED
: css3, flashplayer
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows XP
: -- major with 1 vote (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
: 640794 (view as bug list)
Depends on:
Blocks: 576100 806104
  Show dependency treegraph
 
Reported: 2011-03-24 16:32 PDT by Darin Itamura
Modified: 2014-04-08 06:03 PDT (History)
13 users (show)
roc: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (8.42 KB, patch)
2011-03-26 04:41 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
tnikkel: review+
Details | Diff | Splinter Review

Description Darin Itamura 2011-03-24 16:32:10 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.151 Safari/534.16
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

This seems like a regression bug.  This worked correctly in 3.6.16.  I have included an example below using a YouTube video.  I am using different Flash content in my case by the behavior is the same no matter what flash content is used.

Reproducible: Always

Steps to Reproduce:
1. View HTML included below.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
	<head>
		<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
		<title>Untitled Document</title>
		<style>
			html, body{
				width: 100%;
				height: 100%;
			}
			*{
				margin: 0px;
				padding: 0px;
			}
			#wrapper{
				width: 1000px;
				height: 500px;
				-moz-transform: scale(1);
			}
		</style>
	</head>
	<body>
		<div id="wrapper">
			<iframe title="YouTube video player" width="640" height="390" src="http://www.youtube.com/embed/iBFVrmyald4" frameborder="0" allowfullscreen></iframe>
		</div>
	</body>
</html>
Actual Results:  
Flash content is not displayed.  If the scale rule is removed, flash content is displayed.

Expected Results:  
Flash content should appear and be scaled with the rest of the content.
Comment 1 Darin Itamura 2011-03-24 19:37:50 PDT
Found similar bug but on Mac and an earlier version (included in See Also).  The test case that was included with that bug report also does not work with Firefox 4.0 on Windows XP.  Even with the transparent or opaque wmode, the flash content is still removed.
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-25 13:39:35 PDT
This was done deliberately. Use a windowless Flash object (wmode="opaque" or wmode="transparent") or put it outside a CSS transform. There is no way to implement scaling of a windowed Flash object.
Comment 3 Darin Itamura 2011-03-25 13:58:45 PDT
Definitely.  But the content appears to be removed even with the wmode set to opaque or transparent.  I tried this in yesterday's Minefield build (Windows) using the example that was given in the See also bug (http://uniboard-misc.s3.amazonaws.com/plugin_transform.html) and with my own code.  In both instances the content was removed despite the transparent or opaque wmode.
Comment 4 Darin Itamura 2011-03-25 14:02:05 PDT
I forgot to add that this is also the same behavior that I see with the current release build (Firefox 4 (Windows)).
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-25 14:37:08 PDT
OK http://uniboard-misc.s3.amazonaws.com/plugin_transform.html is definitely a bug!
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-26 04:41:39 PDT
Created attachment 522087 [details] [diff] [review]
fix
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-27 14:54:01 PDT
*** Bug 640794 has been marked as a duplicate of this bug. ***
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-31 19:00:07 PDT
http://hg.mozilla.org/mozilla-central/rev/7dceef1d4e66
Comment 9 AndreiD[QA] 2011-04-06 02:49:20 PDT
I can still see the issue on:
Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110405 Firefox/4.2a1pre
The video in the example html (description) does not play.

However, duped bug in comment 7 (Bug 640794) is fixed.
It's unclear for me whether the issue is fixed or not.
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2011-04-06 11:07:39 PDT
AndreID, if you're talking about the code in comment 0, see comment 2.
Comment 11 Abe 2011-11-02 16:59:56 PDT
This bug seems to still exist in FF7, I have an embed with wmode=transparent, the embed is set dynamically on the page. If I change the scale it is still visible, but if the embed is re-created via js, it disappears!

Hope this helps.
Comment 12 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-11-02 17:13:10 PDT
Please file a new bug for that, with a testcase. Thanks!
Comment 13 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-01-12 21:28:28 PST
This is busted again in current nightly on Mac. Test case here: http://uniboard-misc.s3.amazonaws.com/plugin_transform.html
Comment 14 Timothy Nikkel (:tnikkel) 2012-01-12 23:14:04 PST
Let's open a new bug for that, a patch has already landed from this bug.
Comment 15 Alexander Casassovici 2012-03-22 11:27:55 PDT
This is still broken on FF 11 + and OSX / snow leopard
It was kinda workign on FF10 and below
One funny thing on FF10 : when right clicking on the flash  element the contextual menu does not appear at the click position there's an offset

here's where it breaks my site http://scu.bz/p/1716
Comment 16 Alexander Casassovici 2012-03-22 11:29:44 PDT
note in my case it's a -moz-transform: translate that is my source of problems... but the underlying problem must be the same (correlation or causality... always the same question...)
Comment 17 Alexander Casassovici 2012-03-22 11:36:40 PDT
here's a simple way to reproduce the bug that mimics my setup : http://ksso.net/~alex/ff_bug/moz-transform.html

<html>
<head></head>
<body>
<div style="-moz-transform: translate(0px, 0px); display:block; position:absolute;">
        <div style="-moz-transform: translate(0px, 0px); display:block; position:relative;">
        <iframe width="560" height="315" src="http://www.youtube.com/embed/rn1vJO37yIo?wmode=opaque&autoplay=1" frameborder="0" allowfullscreen></iframe>
        </div>
</div>
</body>
Comment 18 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-03-22 12:10:12 PDT
No-one ever filed a new bug for that :-(. OK, I just filed bug 738392.
Comment 19 [:Aleksej] 2014-04-08 06:03:46 PDT
*** Bug 991060 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.