[e10s] ::InitDB fail to open the right permissions database and prevent fennec to use per site permissions

RESOLVED DUPLICATE of bug 564535

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 564535
8 years ago
8 years ago

People

(Reporter: vingtetun, Unassigned)

Tracking

Dependency tree / graph

Details

When opening a remote tab into fennec it looks like a second permissions database is created but with empty permissions (not a duplicate of the first one). This prevent fennec to store per site permissions.

Looking at the source code for the permissions database it looks like we're failing here:
http://mxr.mozilla.org/mozilla-central/source/extensions/cookie/nsPermissionManager.cpp#143

I wonder if that's related to some profile dir provider not registered and so we're unable to resolve "ProfD" (I don't know this code part at all!)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564535
You need to log in before you can comment on or make changes to this bug.