If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nightly releases are only tarred not gzipped

VERIFIED DUPLICATE of bug 35956

Status

mozilla.org
Miscellaneous
P3
normal
VERIFIED DUPLICATE of bug 35956
17 years ago
17 years ago

People

(Reporter: Marc d'Entremont, Assigned: Mitchell Baker)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
When downloading a nightly build the file is a the name mozilla-blah-blah.tar.gz
when it is not a gzipped file. Very confusing. The extension of gz should be
used to indicate that the file is gzipped.
I've been trying to figure out why the gzipped files were not recognized by gzip
only to find out that I've been duped by the extension.
Odd thing is when I ftp to your site the file download is a valid gzipped file.

cram@24 cram]$ file mozilla-i686-pc-linux-gnu.tar.gz
mozilla-i686-pc-linux-gnu.tar.gz: GNU tar archive
[cram@24 cram]$ gunzip mozilla-i686-pc-linux-gnu.tar.gz

gunzip: mozilla-i686-pc-linux-gnu.tar.gz: not in gzip format
[cram@24 cram]$

Comment 1

17 years ago
Hmm... I think it's a bug of mozilla. It automatically ungzips files when
downloaded. It shouldn't do this for other than viewable files. Especially it
shouldn't do this when you save the file by rightclicking the link. It is a
regression and it was mentioned long time ago in bugzilla but I don't know the
bug number.
(Assignee)

Comment 2

17 years ago
Leaf, do you know the bug number by chance?

Comment 3

17 years ago
It's a dup of bug 35956

Comment 4

17 years ago
marking dupe.

*** This bug has been marked as a duplicate of 35956 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.