Closed Bug 576335 Opened 12 years ago Closed 11 years ago

Lots of cvs and hg failures on N900s

Categories

(Infrastructure & Operations :: NetOps, task)

x86
macOS
task
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 582336

People

(Reporter: jhford, Assigned: dmoore)

References

Details

Example CVS failure:

running cvs -d :pserver:anonymous@63.245.209.14:/cvsroot co -d talos mozilla/testing/performance/talos

cvs checkout: warning: failed to open /home/user/.cvspass for reading: No such file or directory
cvs checkout: Updating talos
U talos/PerfConfigurator.py
U talos/README.txt
U talos/bcontroller.py
U talos/cmanager_linux.py
U talos/cmanager_mac.py
U talos/cmanager_win32.py
U talos/devicemanager.py
U talos/ffprocess.py
U talos/ffprocess_linux.py
U talos/ffprocess_mac.py
U talos/ffprocess_win32.py
U talos/ffprocess_winmo.py
U talos/ffprofile_unix.py
U talos/ffprofile_win32.py
U talos/ffsetup.py
U talos/getInfo.html
U talos/mobile.config
U talos/post_file.py
U talos/remotePerfConfigurator.py
U talos/run_tests.py
U talos/sample.config
U talos/ttest.py
U talos/utils.py
U talos/winmo.config
cvs checkout: Updating talos/base_profile
cvs checkout: Updating talos/base_profile/Cache
U talos/base_profile/localstore.rdf
U talos/base_profile/prefs.js
cvs checkout: Updating talos/base_profile/bookmarkbackups
cvs checkout: Updating talos/breakpad
cvs checkout: Updating talos/breakpad/linux
U talos/breakpad/linux64
cvs checkout: Updating talos/breakpad/maemo
U talos/breakpad/linux/minidump_stackwalk
cvs checkout: Updating talos/breakpad/osx
cvs [checkout aborted]: end of file from server (consult above messages if any)
U talos/breakpad/osx/minidump_stackwalk
program finished with exit code 1


Example HG Fail:
running hg -v clone http://hg.mozilla.org/build/tools tools

requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: connection ended unexpectedly


These devices are able to maintain a stable TCP connection to the buildbot master for hours at a time.
Blocks: 555892
This has been happening since the bug was filed.  Some examples from today:

http://production-mobile-master.build.mozilla.org:8020/builders/n900-gtk%20mozilla-1.9.2%20talos%20ts/builds/154/steps/talos_checkout/logs/stdio

http://production-mobile-master.build.mozilla.org:8020/builders/n900-qt%20electrolysis%20talos%20ts/builds/1/steps/clone_tools/logs/stdio

Raising priority because this is causing intermittent burning of the Mobile tinderbox tree.
Severity: normal → major
Assignee: dmoore+watcher → dmoore
I'm going to roll all of these RF room performance issues into a single bug, as they all appear to have the same root cause.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 582336
Component: Server Operations → Server Operations: Netops
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.