Remove nsICSSStyleRule

RESOLVED FIXED in mozilla5

Status

()

Core
CSS Parsing and Computation
P4
minor
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Craig Topper, Assigned: Craig Topper)

Tracking

(Blocks: 1 bug)

Trunk
mozilla5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 20 obsolete attachments)

12.70 KB, patch
Details | Diff | Splinter Review
8.38 KB, patch
Details | Diff | Splinter Review
3.62 KB, patch
Details | Diff | Splinter Review
85.22 KB, patch
Details | Diff | Splinter Review
5.22 KB, patch
Details | Diff | Splinter Review
6.33 KB, patch
Details | Diff | Splinter Review
(Assignee)

Description

8 years ago
This interface is only implemented by one class so there is no reason for it to exist.
(Assignee)

Comment 1

8 years ago
Created attachment 455923 [details] [diff] [review]
Part 1: Rename CSSStyleRuleImpl
Attachment #455923 - Flags: review?(dbaron)
(Assignee)

Updated

8 years ago
Blocks: 105431
(Assignee)

Comment 2

8 years ago
Created attachment 455924 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl
Attachment #455924 - Flags: review?(dbaron)
(Assignee)

Comment 3

8 years ago
Created attachment 455925 [details] [diff] [review]
Part 3: Rename CSSImportantRule
Attachment #455925 - Flags: review?(dbaron)
(Assignee)

Comment 4

8 years ago
Created attachment 455926 [details] [diff] [review]
Part 4: Remove nsICSSStyleRule and move nsCSSStyleRule to header file
Attachment #455926 - Flags: review?(dbaron)
(Assignee)

Comment 5

8 years ago
Created attachment 455928 [details] [diff] [review]
Part 5: Remove virtual from methods that came from nsICSSStyleRule
Attachment #455928 - Flags: review?(dbaron)
(Assignee)

Updated

8 years ago
Attachment #455928 - Attachment is patch: true
Attachment #455928 - Attachment mime type: application/octet-stream → text/plain
(Assignee)

Comment 6

8 years ago
Created attachment 455957 [details] [diff] [review]
Part 6: DeCOMtaminate the methods that came from nsICSSStyleSheet
Attachment #455957 - Flags: review?(dbaron)
(Assignee)

Comment 7

8 years ago
Patches depend on patches in bug 575901 and bug 571946
Depends on: 571946, 575901
(Assignee)

Updated

8 years ago
Blocks: 577976
(Assignee)

Updated

8 years ago
Attachment #455923 - Flags: review?(dbaron) → review?(bzbarsky)
(Assignee)

Updated

8 years ago
Attachment #455924 - Flags: review?(dbaron) → review?(bzbarsky)
(Assignee)

Updated

8 years ago
Attachment #455925 - Flags: review?(dbaron) → review?(bzbarsky)
(Assignee)

Updated

8 years ago
Attachment #455926 - Flags: review?(dbaron) → review?(bzbarsky)
(Assignee)

Updated

8 years ago
Attachment #455928 - Flags: review?(dbaron) → review?(bzbarsky)
(Assignee)

Updated

8 years ago
Attachment #455957 - Flags: review?(dbaron) → review?(bzbarsky)
Comment on attachment 455923 [details] [diff] [review]
Part 1: Rename CSSStyleRuleImpl

r=bzbarsky
Attachment #455923 - Flags: review?(bzbarsky) → review+
Comment on attachment 455924 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl

r=bzbarsky
Attachment #455924 - Flags: review?(bzbarsky) → review+
Though it's worth double-checking with dbaron on these renames.  Maybe we want to just drop both the "ns" prefix and the "Impl" suffix and stick these in mozilla::css?
Comment on attachment 455925 [details] [diff] [review]
Part 3: Rename CSSImportantRule

r=bzbarsky, with the caveat above.
Attachment #455925 - Flags: review?(bzbarsky) → review+
Comment on attachment 455928 [details] [diff] [review]
Part 5: Remove virtual from methods that came from nsICSSStyleRule

r=bzbarsky
Attachment #455928 - Flags: review?(bzbarsky) → review+
Comment on attachment 455957 [details] [diff] [review]
Part 6: DeCOMtaminate the methods that came from nsICSSStyleSheet

r=bzbarsky
Attachment #455957 - Flags: review?(bzbarsky) → review+
(In reply to comment #10)
> Though it's worth double-checking with dbaron on these renames.  Maybe we want
> to just drop both the "ns" prefix and the "Impl" suffix and stick these in
> mozilla::css?

We probably do, but I don't think it needs to happen here.  This is an improvement over the current state.
(Assignee)

Updated

7 years ago
Attachment #455926 - Flags: review?(bzbarsky)
(Assignee)

Comment 15

7 years ago
Created attachment 461798 [details] [diff] [review]
Part 1: Rename CSSStyleRuleImpl updated to use namespace

Old patch didn't apply anymore so I went ahead and added namespace.
Attachment #461798 - Flags: review?(bzbarsky)
(Assignee)

Updated

7 years ago
Attachment #455923 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Attachment #461798 - Attachment description: 455923: Part 1: Rename CSSStyleRuleImpl updated to use namespace → Part 1: Rename CSSStyleRuleImpl updated to use namespace
(Assignee)

Comment 16

7 years ago
Created attachment 461799 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl updated to use namespace
Attachment #455924 - Attachment is obsolete: true
Attachment #461799 - Flags: review?(bzbarsky)
(Assignee)

Comment 17

7 years ago
Created attachment 461800 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl updated to use namespace.
Attachment #461799 - Attachment is obsolete: true
Attachment #461800 - Flags: review?(bzbarsky)
Attachment #461799 - Flags: review?(bzbarsky)
(Assignee)

Updated

7 years ago
Attachment #461800 - Attachment description: 461799: Part 2: rename DOMCSSStyleRuleImpl updated to use namespace. → Part 2: rename DOMCSSStyleRuleImpl updated to use namespace.
(Assignee)

Comment 18

7 years ago
Created attachment 461801 [details] [diff] [review]
Part 3: Rename CSSImportantRule updated to use namespace
Attachment #461801 - Flags: review?(bzbarsky)
(Assignee)

Updated

7 years ago
Attachment #455925 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Attachment #461801 - Attachment is obsolete: true
Attachment #461801 - Flags: review?(bzbarsky)
(Assignee)

Comment 19

7 years ago
Created attachment 461803 [details] [diff] [review]
Part 3: Rename CSSImportantRule updated to use namespace
Attachment #461803 - Flags: review?(bzbarsky)
(Assignee)

Comment 20

7 years ago
Created attachment 461804 [details] [diff] [review]
Part 4: Remove nsICSSStyleRule and move StyleRule to header file.
Attachment #455926 - Attachment is obsolete: true
Attachment #461804 - Flags: review?(bzbarsky)
(Assignee)

Comment 21

7 years ago
Created attachment 461805 [details] [diff] [review]
Part 5: Remove virtual from methods that came from nsICSSStyleRule
Attachment #455928 - Attachment is obsolete: true
Attachment #461805 - Flags: review?(bzbarsky)
(Assignee)

Comment 22

7 years ago
Created attachment 461807 [details] [diff] [review]
Part 6: DeCOMtaminate StyleRule method signatures
Attachment #455957 - Attachment is obsolete: true
Attachment #461807 - Flags: review?(bzbarsky)

Updated

7 years ago
Blocks: 529750
(Assignee)

Comment 23

7 years ago
Created attachment 468220 [details] [diff] [review]
Part 1: Rename CSSStyleRuleImpl updated to use namespace

Updating for bitrot
Attachment #461798 - Attachment is obsolete: true
Attachment #468220 - Flags: review?(bzbarsky)
Attachment #461798 - Flags: review?(bzbarsky)
(Assignee)

Comment 24

7 years ago
Created attachment 468221 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl updated to use namespace.
Attachment #461800 - Attachment is obsolete: true
Attachment #468221 - Flags: review?(bzbarsky)
Attachment #461800 - Flags: review?(bzbarsky)
(Assignee)

Comment 25

7 years ago
Created attachment 468222 [details] [diff] [review]
Part 3: Rename CSSImportantRule updated to use namespace
Attachment #461803 - Attachment is obsolete: true
Attachment #468222 - Flags: review?(bzbarsky)
Attachment #461803 - Flags: review?(bzbarsky)
(Assignee)

Comment 26

7 years ago
Created attachment 468223 [details] [diff] [review]
Part 4: Remove nsICSSStyleRule and move StyleRule to header file.
Attachment #461804 - Attachment is obsolete: true
Attachment #461804 - Flags: review?(bzbarsky)
Attachment #468223 - Flags: review?(bzbarsky)
(Assignee)

Comment 27

7 years ago
Created attachment 468224 [details] [diff] [review]
Part 5: Remove virtual from methods that came from nsICSSStyleRule
Attachment #461805 - Attachment is obsolete: true
Attachment #468224 - Flags: review?(bzbarsky)
Attachment #461805 - Flags: review?(bzbarsky)
(Assignee)

Comment 28

7 years ago
Created attachment 468225 [details] [diff] [review]
Part 6: DeCOMtaminate StyleRule method signatures
Attachment #461807 - Attachment is obsolete: true
Attachment #468225 - Flags: review?(bzbarsky)
Attachment #461807 - Flags: review?(bzbarsky)
(Assignee)

Comment 29

7 years ago
Created attachment 518272 [details] [diff] [review]
Part 1: Rename CSSStyleRuleImpl updated to use namespace
Attachment #468220 - Attachment is obsolete: true
Attachment #518272 - Flags: review?(bzbarsky)
Attachment #468220 - Flags: review?(bzbarsky)
(Assignee)

Comment 30

7 years ago
Created attachment 518273 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl updated to use namespace.
Attachment #468221 - Attachment is obsolete: true
Attachment #518273 - Flags: review?(bzbarsky)
Attachment #468221 - Flags: review?(bzbarsky)
(Assignee)

Comment 31

7 years ago
Created attachment 518274 [details] [diff] [review]
Part 3: Rename CSSImportantRule updated to use namespace
Attachment #468222 - Attachment is obsolete: true
Attachment #518274 - Flags: review?(bzbarsky)
Attachment #468222 - Flags: review?(bzbarsky)
(Assignee)

Comment 32

7 years ago
Created attachment 518275 [details] [diff] [review]
Part 4: Remove nsICSSStyleRule and move StyleRule to header file.
Attachment #468223 - Attachment is obsolete: true
Attachment #518275 - Flags: review?(bzbarsky)
Attachment #468223 - Flags: review?(bzbarsky)
(Assignee)

Comment 33

7 years ago
Created attachment 518276 [details] [diff] [review]
Part 5: Remove virtual from methods that came from nsICSSStyleRule
Attachment #468224 - Attachment is obsolete: true
Attachment #518276 - Flags: review?(bzbarsky)
Attachment #468224 - Flags: review?(bzbarsky)
(Assignee)

Comment 34

7 years ago
Created attachment 518277 [details] [diff] [review]
Part 6: DeCOMtaminate StyleRule method signatures
Attachment #468225 - Attachment is obsolete: true
Attachment #518277 - Flags: review?(bzbarsky)
Attachment #468225 - Flags: review?(bzbarsky)
Comment on attachment 518272 [details] [diff] [review]
Part 1: Rename CSSStyleRuleImpl updated to use namespace

r=me
Attachment #518272 - Flags: review?(bzbarsky) → review+
Comment on attachment 518273 [details] [diff] [review]
Part 2: rename DOMCSSStyleRuleImpl updated to use namespace.

r=me
Attachment #518273 - Flags: review?(bzbarsky) → review+
Comment on attachment 518274 [details] [diff] [review]
Part 3: Rename CSSImportantRule updated to use namespace

r=me
Attachment #518274 - Flags: review?(bzbarsky) → review+
Comment on attachment 518276 [details] [diff] [review]
Part 5: Remove virtual from methods that came from nsICSSStyleRule

r=me
Attachment #518276 - Flags: review?(bzbarsky) → review+
Comment on attachment 518277 [details] [diff] [review]
Part 6: DeCOMtaminate StyleRule method signatures

r=me
Attachment #518277 - Flags: review?(bzbarsky) → review+
Comment on attachment 518275 [details] [diff] [review]
Part 4: Remove nsICSSStyleRule and move StyleRule to header file.

r=me
Attachment #518275 - Flags: review?(bzbarsky) → review+
Pushed to birch:
           http://hg.mozilla.org/projects/birch/rev/fbce8d3cb670
           http://hg.mozilla.org/projects/birch/rev/4cdf2a9fdade
           http://hg.mozilla.org/projects/birch/rev/055167d450a9
           http://hg.mozilla.org/projects/birch/rev/cbb08a3bd975
           http://hg.mozilla.org/projects/birch/rev/bf3db16c8149
           http://hg.mozilla.org/projects/birch/rev/281f20a0dacd
Whiteboard: fixed-in-birch

Updated

7 years ago
Duplicate of this bug: 604596
https://hg.mozilla.org/mozilla-central/rev/fbce8d3cb670
https://hg.mozilla.org/mozilla-central/rev/4cdf2a9fdade
https://hg.mozilla.org/mozilla-central/rev/055167d450a9
https://hg.mozilla.org/mozilla-central/rev/cbb08a3bd975
https://hg.mozilla.org/mozilla-central/rev/bf3db16c8149
https://hg.mozilla.org/mozilla-central/rev/281f20a0dacd
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Priority: -- → P4
Resolution: --- → FIXED
Whiteboard: fixed-in-birch
Target Milestone: --- → mozilla2.2
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.