Last Comment Bug 576883 - AIX compilation errors in media/liboggplay and media/liboggz
: AIX compilation errors in media/liboggplay and media/liboggz
Status: RESOLVED FIXED
(NOPTB patch files committed in 1.9.2...
: verified1.9.1, verified1.9.2
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 1.9.1 Branch
: PowerPC AIX
: -- normal (vote)
: ---
Assigned To: Uli Link (:ul-mcamafia)
:
: Maire Reavy [:mreavy]
Mentors:
: 499270 535769 (view as bug list)
Depends on:
Blocks: 576887
  Show dependency treegraph
 
Reported: 2010-07-04 12:06 PDT by Uli Link (:ul-mcamafia)
Modified: 2011-03-01 01:39 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.9-fixed
.12-fixed


Attachments
Patch for 1.9.1 branch, AIX port (2.12 KB, patch)
2010-07-04 12:06 PDT, Uli Link (:ul-mcamafia)
cajbir.bugzilla: review-
Details | Diff | Splinter Review
Adds support for AIX on stable branches (6.80 KB, patch)
2010-07-15 01:18 PDT, Uli Link (:ul-mcamafia)
cajbir.bugzilla: review+
dveditz: approval1.9.2.9+
dveditz: approval1.9.1.12+
Details | Diff | Splinter Review
patch adjusted/manually merged for branch 1.9.2 (6.70 KB, patch)
2010-08-06 11:59 PDT, Uli Link (:ul-mcamafia)
no flags Details | Diff | Splinter Review
Followup patch adding the NPOTB upstream patch files (2.45 KB, patch)
2010-09-04 08:25 PDT, Uli Link (:ul-mcamafia)
dveditz: approval1.9.2.11+
dveditz: approval1.9.1.14+
Details | Diff | Splinter Review

Description Uli Link (:ul-mcamafia) 2010-07-04 12:06:21 PDT
Created attachment 455967 [details] [diff] [review]
Patch for 1.9.1 branch, AIX port

Some subtle patches for successfully building on AIX
Comment 1 Uli Link (:ul-mcamafia) 2010-07-04 12:11:53 PDT
Same patch applies cleanly to branch 1.9.2.
Branches 1.9.1 and 1.9.2 only.
Comment 2 cajbir (:cajbir) 2010-07-14 17:31:16 PDT
Comment on attachment 455967 [details] [diff] [review]
Patch for 1.9.1 branch, AIX port

For both the liboggplay and liboggz changes we'll need a .patch file with these changes, include it in the relevant media subdirectory, add a line to update.sh to apply it and update README_MOZILLA to note the patch file and this bug. There should be other patches in these directories to see how this works.

Are the dirac.c changes needed? As far as I can recall we don't use or build dirac support.
Comment 3 Uli Link (:ul-mcamafia) 2010-07-15 01:18:05 PDT
Created attachment 457514 [details] [diff] [review]
Adds support for AIX on stable branches

Reworked according to comment #2
recreated as upstream patches, included in update.sh and README_MOZILLA + in applied state.
Comment 4 Uli Link (:ul-mcamafia) 2010-07-15 01:19:58 PDT
The dirac.c patch is needed on AIX and removes some CR/LF line endings.
Comment 5 Daniel Veditz [:dveditz] 2010-08-06 10:49:58 PDT
Comment on attachment 457514 [details] [diff] [review]
Adds support for AIX on stable branches

Approved for 1.9.2.9 and 1.9.1.12, a=dveditz for release-drivers
Comment 6 Uli Link (:ul-mcamafia) 2010-08-06 11:34:30 PDT
Hmmm, there is a little conflict with the fixes of Bug 533822
in branch 1.9.2 update.sh and README_MOZILLA files. So I will adjust/recreate
the patch for branch 1.9.2. The patched sources itself have cleanly applied.
Comment 7 Uli Link (:ul-mcamafia) 2010-08-06 11:59:54 PDT
Created attachment 463619 [details] [diff] [review]
patch adjusted/manually merged for branch 1.9.2

The applied source patches have applied cleanly, only recreated the NPOTB in both update.sh and README_MOZILLA files, as there was a change within the context.
The original patch still applied cleanly on a freshly pulled branch 1.9.1.
Comment 8 Daniel Veditz [:dveditz] 2010-08-22 00:22:10 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/2a5cdb29af2a
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/49ed52dfa7a9

It's not clear to me if this change is needed on the trunk so I'll leave it open. If it's for the trunk it'll need explicit approval there, too, now.
Comment 9 Matthew Gregan [:kinetik] 2010-08-22 01:52:41 PDT
oggz and oggplay aren't on trunk, so this bug is branch only.
Comment 10 Uli Link (:ul-mcamafia) 2010-08-23 04:15:11 PDT
The NPOTB added files

media/liboggplay/oggplay-aix.patch
media/liboggz/oggz-aix.patch

have missed adding/landing.
Comment 11 Uli Link (:ul-mcamafia) 2010-09-04 08:25:54 PDT
Created attachment 472162 [details] [diff] [review]
Followup patch adding the NPOTB upstream patch files

Only the upstream patch files should be added, or the update.sh script wom't find it's patch. Carrying forward r+
Comment 12 Daniel Veditz [:dveditz] 2010-09-27 14:02:52 PDT
Comment on attachment 472162 [details] [diff] [review]
Followup patch adding the NPOTB upstream patch files

Approved for 1.9.2.11 and 1.9.1.14, a=dveditz

Sorry I forgot these.
Comment 13 Daniel Veditz [:dveditz] 2010-09-27 14:17:03 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/1c08c7f691b2
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/c5bd841d7226

Although it's going to screw up our queries, I'm not going to update the status1.9.x fields. Seems more appropriate for them to reflect when the compilation errors were fixed.
Comment 14 Uli Link (:ul-mcamafia) 2011-03-01 01:36:41 PST
*** Bug 499270 has been marked as a duplicate of this bug. ***
Comment 15 Uli Link (:ul-mcamafia) 2011-03-01 01:39:11 PST
*** Bug 535769 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.