Closed Bug 576991 Opened 10 years ago Closed 10 years ago

file picker does not open file picker dialog

Categories

(Core Graveyard :: File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla2.0b2

People

(Reporter: info, Assigned: legion)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; en-US; rv:2.0b2pre) Gecko/20100705 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; en-US; rv:2.0b2pre) Gecko/20100705 Minefield/4.0b2pre

Since either today or yesterday, when using Minefield-beta, clicking on an input type=file button (or inside the accompanying filename input) does not open a file picker dialog anymore.
This seems only the case when the config setting ui.allow_platform_file_picker is set to false.
When the config is set to true, I get the Gtk-based file picker.
Prior to yesterday it used to work correctly.


Reproducible: Always

Steps to Reproduce:
1. make sure the config setting ui.allow_platform_file_picker is set to false
2. click on the input-type=file Browse... button (or inside the accompanying input)
3.
Actual Results:  
No dialog is shown

Expected Results:  
I hoped to see a file picker dialog..
This patch fix this error.
Component: General → File Handling
Product: Firefox → Core
QA Contact: general → file-handling
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 578955
Attachment #456347 - Flags: review?(bzbarsky)
Comment on attachment 456347 [details] [diff] [review]
nsFilePicker fix [Checkin: comment 4]

r=bzbarsky
Attachment #456347 - Flags: review?(bzbarsky) → review+
Assignee: nobody → legion
Comment on attachment 456347 [details] [diff] [review]
nsFilePicker fix [Checkin: comment 4]

http://hg.mozilla.org/mozilla-central/rev/9a924c95c6dd
Attachment #456347 - Attachment description: nsFilePicker fix → nsFilePicker fix [Checkin: comment 4]
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b2
Version: unspecified → Trunk
Blocks: 579765
No longer blocks: 579765
Depends on: 579765
Why was the GTK ifdef removed from nsFilePicker.js.in? It was there on purpose, and should only be used for platforms where there isn't a native picker. This caused bug 579765.
This is my mistake. I commented it already in #579765 and maked a patch, but you faster.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.