Some chrome images are not loading properly (XUL scrollbars, profile manager icons, Fennec icons)

VERIFIED FIXED

Status

()

Core
DOM
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Chwiej Pawel, Assigned: Benjamin Smedberg)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 5.1; U; pl) Presto/2.6.30 Version/10.60
Build Identifier: Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:2.0b2pre)   Gecko/20100705 Namoroka/4.0b2pre Fennec/2.0a1pre

Maemo5
Gecko/20100705


Reproducible: Always

Steps to Reproduce:
1. Open any page
2. Open tabs strip

Actual Results:  
'New tab' button is missing


Expected Results:  
'New tab' button should be visible at the bottom-left
Duplicate of this bug: 577474
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can reproduce this on Android and desktop Linux too.  After some investigation, it looks like the images for both the newtab and remotetabs buttons are failing to load at startup, but other images do appear correctly (like the non-disabled remotetabs-button image, or the :active image for the newtab-button).

Maybe the chrome: URIs are not yet working for some reason when these buttons first load?  The image does appear in the browser when I enter its chrome: URI in the urlbar.
OS: Linux → All
Hardware: Other → All
Looks like something in mozilla-central caused this regression.  A randomly-chosen revision pushed on July 2 does not have bug:
http://hg.mozilla.org/mozilla-central/rev/d1be3b90c8d4

but the nightly build from July 3 does have the bug.
It looks like this change from Bug 576540 is the culprit:
http://hg.mozilla.org/mozilla-central/rev/f9e9f951c0ab
Blocks: 576540
Summary: 'New tab' button is missing → Some chrome images are not loading in Fennec
Duplicate of this bug: 577078
(Assignee)

Comment 6

8 years ago
Created attachment 456477 [details] [diff] [review]
Fix nsContentUtils::LoadImage

Whoops. I added the extra space to avoid re-indenting, but I can reindent on checkin if you want.
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #456477 - Flags: review?(bzbarsky)
Comment on attachment 456477 [details] [diff] [review]
Fix nsContentUtils::LoadImage

Yeah, just reindent on checkin, please.
Attachment #456477 - Flags: review?(bzbarsky) → review+
Component: General → Graphics
Product: Fennec → Core
QA Contact: general → thebes
blocking2.0: --- → ?
Summary: Some chrome images are not loading in Fennec → Some chrome images are not loading properly (XUL scrollbars, profile manager icons, Fennec icons)
Component: Graphics → DOM
QA Contact: thebes → general
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/2acaeec7604f
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 576872

Updated

8 years ago
Duplicate of this bug: 576813

Comment 11

8 years ago
Thanks for the fix!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
blocking2.0: ? → final+
You need to log in before you can comment on or make changes to this bug.