Closed Bug 577334 Opened 11 years ago Closed 11 years ago

Add a way to limit the number of successive alert()

Categories

(Camino Graveyard :: Annoyance Blocking, enhancement)

All
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 432687

People

(Reporter: contact, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (MultiLang) (like Firefox/3.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (MultiLang) (like Firefox/3.0.19)

Some pages like http://rickrolled.fr/ (use with caution) use a lot of alert() to annoy the user.
It would be nice to have a way to limit that.

Reproducible: Always




Opera asks if he should stop the script.
I think this bug about loops specifically.
Sometimes there are just a lot of successive alert().
But maybe the solution of the other bug will work for this too.
A number of similar bugs have been duped to bug 432687. But yeah, this is basically what bug 61098 is about.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: eviltraps
You need to log in before you can comment on or make changes to this bug.