Closed Bug 577489 Opened 9 years ago Closed 9 years ago

Recurring return receipt acknowlegement

Categories

(Thunderbird :: General, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 558543

People

(Reporter: edwin, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 Glue/4.5 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1 ThunderBrowse/3.2.8.1

Any time someone sends me a mail requesting a Return Receipt, upon reading the mail I get the warning "The sender of this message has asked to be notified when you read this message. Do you wish to notify the sender" and the options to "Ignore Request" or "Send Receipt" (as I would expect). Clicking on an option sends the receipt or ignores it accordingly and the warning goes away. HOWEVER, if I then close the message and re-open it the warning and option buttons return (and will perform their respective functions if clicked). It doesn't matter if ignore it or send the receipt - the warning always returns when the message is re-opened. It is not sender or mail account specific. When I click "Send Receipt" the receipt IS sent (as correspondents are complaining about my multiple acknowledgements!)


Reproducible: Always

Steps to Reproduce:
1. Click on incoming message where sender has requested return receipt
2. Click on "Send Receipt" (Sender will receive receipt)
3. Close message
4. Re-open message - warning box to send/ignore receipt returns
Actual Results:  
Sender correctly receives return receipt. If I re-open message and click "Send receipt" sender receives another receipt.

Expected Results:  
"Ignore Request" / "Send Receipt" should only be queried when first opening message. Once send receipt is ignored or sent message should not re-occur when re-opening message

New bug in V3.1 - previous versions worked correctly.
ALLEGEDLY problem only occurs with incoming messages requesting send receipts from non-Thunderbird users.
I confirm the bug on TB 3.1 final on Kubuntu Linux 10.04, downloaded from mozilla.org (i.e. not installed from the repositories). The bug also appears in safe mode.
For what is worth, my local account is about 5 GB (Inbox 2+, Sent 2+). It worked with no problems with 3.0.6 though.
I confirm the bug on TB 3.1 on Windows XP SP3 (and maybe Vista and 7).
Previous versions works fine (I upgraded from 3.0.5).
Whiteboard: dupme
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 558543
You need to log in before you can comment on or make changes to this bug.