If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird hangs when connection error occurs while add attachment dialog is open

RESOLVED DUPLICATE of bug 482811

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 482811
7 years ago
7 years ago

People

(Reporter: Eduard Grebe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

When Thunderbird drops down an error message (like a server connection error), while you have clicked "add attachment" in a new message dialog, you get stuck in an infinite loop of some kind -- Neither adding the attachment or "cancel" in the add attachment dialog works. The error drop-down dialog's text is not visible. The attachment dialog remains responsive, but not its buttons. The only way out is to kill Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.Make sure your internet connection is flakey
2.Click new message
3.Click add attachment
4 [review].Wait for an error message
Actual Results:  
You can't get out of the add attachment dialog to dismiss the error dialog and the text in the error dialog is not visible

Expected Results:  
You should be able to complete attaching the file or at least cancel in order to dismiss the error message

I will add a screenshot to show you what I mean.
(Reporter)

Comment 1

7 years ago
Created attachment 456457 [details]
Screenshot of the dialog of death that you can't get out of
this is actually a "common" issue.
Severity: normal → critical
Whiteboard: dupme

Comment 3

7 years ago
I've seen this occur in Firefox under OS X under certain hard-to-reproduce conditions; there it didn't even need a file selection dialog up. Basically when an alert pane of the type depicted pops up, and no buttons are rendered, there's no way to dismiss it. Possible flaw in the Mozilla UI area.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 482811
You need to log in before you can comment on or make changes to this bug.