Last Comment Bug 577872 - Create WebM versions of Ogg reftests
: Create WebM versions of Ogg reftests
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Mac OS X
-- normal (vote)
: mozilla8
Assigned To: Paul Adenot (:padenot) [on PTO until 2017-03-06]
:
: Maire Reavy [:mreavy] Please needinfo me
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-10 19:11 PDT by Matthew Gregan [:kinetik]
Modified: 2011-08-01 08:00 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0 - convertion from OGG testsuite (35.95 KB, patch)
2011-07-22 07:25 PDT, Paul Adenot (:padenot) [on PTO until 2017-03-06]
no flags Details | Diff | Splinter Review
Patch v1 -- Added offset test back (39.04 KB, patch)
2011-07-22 10:54 PDT, Paul Adenot (:padenot) [on PTO until 2017-03-06]
kinetik: review+
Details | Diff | Splinter Review
Patch v2 - Removed invalid test poster-14 (38.07 KB, patch)
2011-07-29 06:28 PDT, Paul Adenot (:padenot) [on PTO until 2017-03-06]
no flags Details | Diff | Splinter Review

Description User image Matthew Gregan [:kinetik] 2010-07-10 19:11:04 PDT
We have no reftest coverage for WebM right now, and we need it.
Comment 1 User image Paul Adenot (:padenot) [on PTO until 2017-03-06] 2011-07-21 10:12:59 PDT
How these would be different from the ogg reftests ? Could this be achieved using a few sed and ffmpeg invocations ?
Comment 2 User image Chris Pearce (:cpearce) 2011-07-21 18:28:31 PDT
WebM reftests would test the WebM decoder backend. You should be able to just convert the Ogg files used by the ogg reftests to WebM using ffmpeg, and create new tests for them identical to the existing Ogg reftests.
Comment 3 User image Paul Adenot (:padenot) [on PTO until 2017-03-06] 2011-07-22 07:25:56 PDT
Created attachment 547684 [details] [diff] [review]
Patch v0 - convertion from OGG testsuite

It appears that offset-1.xhtml fails with the webm backend. It is related to video cropping, and I don't know if this is supported in the webm format, since all my video players and browsers don't crop the video (as they do using the ogg version of the file).

I've consequently removed that test in this patch, which is basically a |sed -i 's/\(.*\)ogv/\1webm/g' *html| invocation followed by a couple of ffmpeg call.
Comment 4 User image Timothy B. Terriberry (:derf) 2011-07-22 07:29:04 PDT
(In reply to comment #3)
> It appears that offset-1.xhtml fails with the webm backend. It is related to
> video cropping, and I don't know if this is supported in the webm format,

It is, but the crop rectangle must be specified at the container level, and not the codec level like it is with Theora. I would not be surprised if whatever you used to do the conversion didn't preserve it correctly.
Comment 5 User image Paul Adenot (:padenot) [on PTO until 2017-03-06] 2011-07-22 10:54:46 PDT
Created attachment 547745 [details] [diff] [review]
Patch v1 -- Added offset test back

I finally managed to get an offset reftest working, so the suite is now as complete as the ogg testsuite.

I used mkvmerge --cropping 1:29,4,6,31 --display-dimension 1:29x29 to get a correct video.
Comment 6 User image Paul Adenot (:padenot) [on PTO until 2017-03-06] 2011-07-26 16:57:30 PDT
kinetik, several of these tests are failing on OSX 64bit. I've set up a mac today to try to reproduce the failure, but I haven't been successful so far. I plan to investigate tomorrow.

try push : http://tbpl.mozilla.org/?tree=Try&rev=01e26493cec8
Comment 7 User image Matthew Gregan [:kinetik] 2011-07-28 16:48:32 PDT
Paul, can you please remove poster-14.html before you check in?  It's an invalid test; see bug 622059.
Comment 8 User image Paul Adenot (:padenot) [on PTO until 2017-03-06] 2011-07-29 06:28:09 PDT
Created attachment 549355 [details] [diff] [review]
Patch v2 - Removed invalid test poster-14

Here is the same patch without the test mentioned in the previous comment.
Comment 9 User image Marco Bonardo [::mak] 2011-08-01 08:00:16 PDT
http://hg.mozilla.org/mozilla-central/rev/d108ca6c87fd

Note You need to log in before you can comment on or make changes to this bug.