F6 doesn't work when message summary view is shown (operate on collapsed)

RESOLVED FIXED in Thunderbird 8.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: torhu, Assigned: squib)

Tracking

({access, regression})

Thunderbird 8.0
x86
Windows 7
access, regression
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird6-, thunderbird7+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

This happens when you select either multiple emails, or a collapsed thread.  This activates the 'message summary view' in the preview pane.  If focus is on the message list, F6 has no effect.

Shift-F6 works, but only takes you to the folder list, pressing it again does not take you to the preview pane.

The workaround is to deselect all but one message, then you can use F6.

Reproducible: Always

Steps to Reproduce:
1. Select two messages in the message list by hold ctrl and pressing space(emails, not news posts)
2. Press F6.
Actual Results:  
Nothing happens.

Expected Results:  
Focus moves to the preview pane.

T
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1

Comment 1

7 years ago
yeah, only happens if mail.operate_on_msgs_in_collapsed_threads.
makes one wonder just how many people use F6!

unclear if this regressed with bug 448288, or more recently.
perhaps this should have been confirmed long ago.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: F6 doesn't work when message summary view is shown → F6 doesn't work when message summary view is shown (operate on collapsed)
(Assignee)

Comment 2

7 years ago
Taking this, since I stumbled upon the code while trying to fix something else. I have a patch, but it needs tests...
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Created attachment 547896 [details] [diff] [review]
Fix this

Here's a fix. I cleaned up the code a bit to make it easier for people to add more panes in the future (for instance, it might be useful to make F6 eventually take you to the attachment pane if it's visible). Note, I did have to change top.document.commandDispatcher.focusedElement to top.document.activeElement, since the former returns null when focus is on the multimessage. I don't think that causes any real problems though.

:asuth, you like 3pane bugs, right? Of course, feel free to reassign review if need be. :)
Attachment #547896 - Flags: review?(bugmail)
Comment on attachment 547896 [details] [diff] [review]
Fix this

gorgeous.

nit: please expand/alter the comment "// Special-case focusing the message pane." to briefly explain why we need to special-case it, as it's not clear from the code (while the special-casing is arguably clear from the control flow.)
Attachment #547896 - Flags: review?(bugmail) → review+
(Assignee)

Comment 5

7 years ago
Checked in with a better comment: http://hg.mozilla.org/comm-central/rev/c72b0134955a
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
How appropriate would it be to take this on 6/7 given this is a regression in 5? Will extensions have already worked around it for 6?
tracking-thunderbird6: --- → ?
tracking-thunderbird7: --- → ?
(Assignee)

Comment 7

7 years ago
I believe it's a regression from 3.0, actually.

Comment 8

7 years ago
(In reply to comment #7)
> I believe it's a regression from 3.0, actually.

you would think.

(In reply to comment #6)
> How appropriate would it be to take this on 6/7 given this is a regression
> in 5? Will extensions have already worked around it for 6?

because it affects accessibility (really, I've been PMing with an affected user), and we are the "premier" accessibility-enabled mail client, I suggest it must not wait until 8. Perhaps it is late to take for v6? But should be OK for 7. Plus, it adds tests.
Keywords: access
Version: 3.1 → 3.0
Ok, given the regression range, we'll take this for 7 as we've got time to test it, but won't for 6.
tracking-thunderbird6: ? → -
tracking-thunderbird7: ? → +
Attachment #547896 - Flags: approval-comm-beta+
Comment on attachment 547896 [details] [diff] [review]
Fix this

Thunderbird 7 is currently on aurora not beta...
Attachment #547896 - Flags: approval-comm-beta+ → approval-comm-aurora+
Checked in: http://hg.mozilla.org/releases/comm-aurora/rev/9c7f4200754d
status-thunderbird7: --- → fixed
You need to log in before you can comment on or make changes to this bug.