Aero effects crash for unknown reason

RESOLVED DUPLICATE of bug 545892

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 545892
8 years ago
7 years ago

People

(Reporter: richthegeek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

Aero effects crashed randomly. I have no idea why this has happened.

It takes on a different appearance under two situations. Most of the time it looks like this, when maximised, or when windowed but without focus.
http://bit.ly/9Uozjj

When windowed with focus, it looks like this:
http://bit.ly/cV0STA

Wasn't doing anything special at the time (watching something on iPlayer and browsing Facebook), I have a high-end gaming rig so Aero is usually rock solid.

I think Firefox was left open whilst I was playing a game (Supreme Commander 2) so Windows itself might have temporarily turned off Aero and Firefox didn't reinitialise it or sth.

Reproducible: Didn't try

Steps to Reproduce:
No idea - possibly try running a game in fullscreen mode whilst its running.
Actual Results:  
See screenshots from my post (bit.ly shots)

Expected Results:  
See screenshots from http://www.mozilla.com/en-US/firefox/4.0b1/whatsnew/

Updated

8 years ago
Blocks: 513162
Component: Theme → Widget: Win32
Product: Firefox → Core
QA Contact: theme → win32

Comment 1

8 years ago
Yeah, I can repoduce it when back to Firefox from any Steam game.
I can't reproduce this with glass. It looks like you're running Aero Basic (sometimes games will disable this automatically for a performance boost). I'm not sure if we properly support the aero basic theme with the new titlebar button. CC'ing Jim who should know better than I...
(Reporter)

Comment 3

8 years ago
Rob; afaik I'm running the full glass effect. Whatever the Windows 7 default is when the WEI is 5.9 (7.x for all but HDD). 

However, this is *after* running a game so it will have switched out whilst playing and then back on after quitting. Other browsers using this sort of extended glass look (IE8, Chrome) seem to transition back to full glass without issue, whilst FF has issue.
Curious. Does this only happen after you quit the game (i.e. if you alt-tab out in the middle, is everything ok)?

We have code to handle the transition to/from glass but perhaps we're not setting the margins right or we broke it recently when landing the margins change.

Comment 5

8 years ago
Possibly a dupe of bug 576168? (which we duped to the oopp aero bug 545892.) Not sure what happens when we fall our of aero in this situation, but I don't think a theme changed event gets fired.
(Reporter)

Comment 6

8 years ago
Happened again with a DX10 game (metro 2033)

Updated

8 years ago
Depends on: 545892

Comment 7

7 years ago
I had the same problem (several times), but I haven't played any DX or flash game. The title bar accidentally switches back to the basic theme. (Picture Nr. 1) After I open a new window, the new window uses normally Aero glass. (Nr. 5) After maximizing the original window, the tab bar becomes fully transparent (I can see my background or any window opened below Minefield) (Nr. 1), the title bar remains Aero basic. After I press alt to show the menu bar, the title bar also becomes transparent, and the minimize, restore down and close button disappears. (Nr. 3) After I restored down the window, instead of the transparent title bar and tab bar, it became black. (Nr. 4) After switching to another window and back, the aero basic title bar appears again. (Nr. 2)

Comment 8

7 years ago
Created attachment 458625 [details]
Screenshot for my comment (Nr. 7)

Comment 9

7 years ago
Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

Had exactly the same problem with Fx 3.6 + some "glass" extensions and themes. Now updated to 4.0b2 and glitch happens again. It seems to have some connection to responsiveness of the application. Tried cleaning my profile, uninstalling extensions and compacting SQLite files and now the theme seems to crash less often. Starting with fresh profile helped a lot, but it still happens from time to time. Using Win7 x86, so x64 flag might not be appropriate.

Since I use custom themes on Win7, I tried moving my profile to a fresh Win7 install (with no uxtheme hack) to rule out bugs in the theme patches and/or unofficial themes. Problem still persists, though.

Also once the theme crashes, window buttons become unaccessible (not just invisible, they seem to be moved off-window or something). System shortcuts still work, but it must be annoying and confusing for common user.

Comment 10

7 years ago
I have exactly this problem, i haven't tried to reproduce it yet but looking through the comments i also regularly play steam games and this could be a cause.

Updated

7 years ago
No longer blocks: 513162

Comment 11

7 years ago
i also have exactly the same problem, but a new window is always okay
btw i think this is the same as https://bugzilla.mozilla.org/show_bug.cgi?id=586716

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
No longer depends on: 545892
Resolution: --- → DUPLICATE
Duplicate of bug: 545892
You need to log in before you can comment on or make changes to this bug.