Closed Bug 578170 Opened 12 years ago Closed 12 years ago

Undo of persona removal leaves undo option showing in add-on manager

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 571248
Tracking Status
blocking2.0 --- final+

People

(Reporter: iannbugzilla, Unassigned)

Details

Steps to reproduce
1/ Install a persona
2/ Go to themes in add-on manager
3/ Select remove for new persona
4/ Select undo

Expected result
1/ Persona reappears
2/ Undo option disappears

Actual result
1/ Persona reapperas
2/ Undo option still appears
3/ Message in error console:
Error: Theme is not marked to be uninstalled
Source File: resource://gre/modules/LightweightThemeManager.jsm
Line: 467
Component: Themes → Add-ons Manager
QA Contact: themes → add-ons.manager
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553494
Status: RESOLVED → REOPENED
blocking2.0: --- → final+
Depends on: 553494
Resolution: DUPLICATE → ---
Summary: Undo of theme removal leaves undo option showing in add-on manager → Undo of persona removal leaves undo option showing in add-on manager
But it is a dupe of bug 571248.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
No longer depends on: 553494
Resolution: --- → DUPLICATE
Duplicate of bug: 571248
You need to log in before you can comment on or make changes to this bug.