Setup recycled bm-xserve01,02,05 as slaves for geriatric-master

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: joduinn, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [hardware])

Now that some xserves are no longer being used for TB2.0 and FF3.0 builds, we can recycle them as slaves attached to geriatric-master. 

(These specific xserves should go to geriatric, as they are all PPC based).

bm-xserve01
bm-xserve02
bm-xserve03
bm-xserve04
bm-xserve05

We're waiting for next colo trip to verify CPU/specs of
bm-xserve08
bm-xserve10 which seems to be also known as fx-mac-1.9-slave2 
bm-xserve20
...before we decide what to do with them.
Priority: -- → P2
Whiteboard: [hardware]

Comment 1

8 years ago
bm-xserve08 - Dual-Core Intel Xeon 2.66Ghz 4GB RAM, 2x 80GB SAS drives

bm-xserve10 - aka fx-mac-1.9-slave2 - same as above, but physically missing one drive

bm-xserve20 - aka qm-xserve01 - also same specs.

(In reply to comment #1)
> bm-xserve08 - Dual-Core Intel Xeon 2.66Ghz 4GB RAM, 2x 80GB SAS drives
> 
> bm-xserve10 - aka fx-mac-1.9-slave2 - same as above, but physically missing one
> drive
> 
> bm-xserve20 - aka qm-xserve01 - also same specs.

These machines are not useful for geriatric master.
We should use 08/10/20 like we do 06/07/.../21, as fast builders for m-c and friends. The only decision is if we want to use them for 10.6 or 10.5, and I'd probably lean towards 10.6 since we only have minis there right now.
(In reply to comment #3)
> We should use 08/10/20 like we do 06/07/.../21, as fast builders for m-c and
> friends. The only decision is if we want to use them for 10.6 or 10.5, and I'd
> probably lean towards 10.6 since we only have minis there right now.

Agreed. Bug#580346 filed to track getting bm-xserve08/10/20 into production. 

Remaining work here is getting bm-xserve01/02/03/04/05 setup as slaves on geriatric-master.
> Remaining work here is getting bm-xserve01/02/03/04/05 setup as slaves on
> geriatric-master.

03 and 04 are already connected to, and working for, geriatric master.  Unless we are relocating these machines to MV, we shouldn't touch these machines.
(In reply to comment #5)
> > Remaining work here is getting bm-xserve01/02/03/04/05 setup as slaves on
> > geriatric-master.
> 
> 03 and 04 are already connected to, and working for, geriatric master.  Unless
> we are relocating these machines to MV, we shouldn't touch these machines.

Nothing should be moved. 03,04 should stay where they are in MPT. I believe 01,02,05 should also be in MPT.

Not sure if these need to be reimaged again (see bug#581205). Will need to get configured, attached to masters, and accepting jobs.
Depends on: 581205
Summary: Setup recycled bm-xserves as slaves for geriatric-master → Setup recycled bm-xserve01,02,05 as slaves for geriatric-master
Duplicate of this bug: 581210
Assignee: nobody → jhford
FWIW, 02 is currently down right now.
(Assignee)

Updated

7 years ago
Depends on: 620948
(Assignee)

Updated

7 years ago
Depends on: 629511
Whats the status here ? And are these old-generation-slaves something slaveduty could handle?
(Assignee)

Updated

7 years ago
Assignee: jhford → nobody
Priority: P2 → P3
Whiteboard: [hardware] → [hardware][slaveduty]
John, can you offer some guidance here?
bm-xserve02 is back up from its reboot, and ready for action .. whatever action that might be.
(Assignee)

Comment 12

7 years ago
(In reply to comment #11)
> bm-xserve02 is back up from its reboot, and ready for action .. whatever action
> that might be.

The passwords were out-of-date on this box, so I updated them to the current ones (ssh and VNC, for cltbld and root).

jhford: IIRC, we decided that the geriatric testing was still required at some level. Can you provide Dustin (or whoever else happens to be on slaveduty) with the info they need to get these slaves setup? Feel free to put it back into the pool once that info is in the bug. Thanks!
Assignee: nobody → jhford
(In reply to comment #12)
> (In reply to comment #11)
> > bm-xserve02 is back up from its reboot, and ready for action .. whatever action
> > that might be.
> 
> The passwords were out-of-date on this box, so I updated them to the current
> ones (ssh and VNC, for cltbld and root).
> 
> jhford: IIRC, we decided that the geriatric testing was still required at some
> level. 

Yep, as I understand from the email thread the plan is to leave what we have going now as is.

> Can you provide Dustin (or whoever else happens to be on slaveduty) with
> the info they need to get these slaves setup? Feel free to put it back into the
> pool once that info is in the bug. Thanks!

Sure,  I don't know what state these machines are in, but the setup is in

https://wiki.mozilla.org/ReferencePlatforms/UnitTestOnly/10.5-Xserve.

The machines are already in the master configs.
Assignee: jhford → nobody
(Assignee)

Updated

7 years ago
Duplicate of this bug: 649710
(Assignee)

Comment 15

7 years ago
/me grumbles and takes this bug, if only so I never have to see it again.
Assignee: nobody → coop
Whiteboard: [hardware][slaveduty] → [hardware]
bm-xserve03 and bm-xserve04 both have intel nagios binaries on them, which we should fix (bug 626088).  However, they are running on the geriatric master, burning builds like there's no tomorrow.

bm-xserve01, 02, and 05 are not connected to the master. I think they all need to be set up as per the refimage link in comment 13.
Depends on: 626088
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
(Assignee)

Comment 17

7 years ago
(In reply to comment #16)
> bm-xserve03 and bm-xserve04 both have intel nagios binaries on them, which we
> should fix (bug 626088).  However, they are running on the geriatric master,
> burning builds like there's no tomorrow.

Sadly, I think that's the status quo on the geriatric master. The single Windows slave isn't even connected.

Slaves are setup and connected now. Working on getting buildbot to auto-start on boot.
(Assignee)

Comment 18

7 years ago
(In reply to comment #16)
> bm-xserve03 and bm-xserve04 both have intel nagios binaries on them, which we
> should fix (bug 626088).

Where can I grab the PPC binary so I can get it installed on all 5 xserves?
(Assignee)

Comment 19

7 years ago
(In reply to comment #17)
> Working on getting buildbot to auto-start on boot.

Done, and docs updated.
(Assignee)

Updated

7 years ago
Blocks: 651558
(Assignee)

Comment 20

7 years ago
(In reply to comment #18)
> Where can I grab the PPC binary so I can get it installed on all 5 xserves?

Nevermind, I just re-compiled them. Filed bug 651558 to get the nagios checks re-enabled.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You, good sir, are my hero.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.