Setup recycled bm-xserve08,10,20,23,24 as 10.5 build slaves on TryServer

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: joduinn, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [hardware][buildslave])

Attachments

(3 attachments, 1 obsolete attachment)

Lets use bm-xserve08/10/20 as fast builders in production pool, so they would do 10.6 builds for m-c and the project branches. 

Do we have a 10.6 ref image we can have IT apply to xserves?
We have no 10.6 image for xserves. We'll have to rebuild it from the base 10.6.2 image.
Whiteboard: [hardware] → [hardware][buildduty]
Duplicate of this bug: 581209
Decreasing priority until dependent bug is fixed.
Priority: -- → P4
As we do not yet have a 10.6 xserve ref image, we're going to use those xserves as 10.5 xserve builders. At least that way they do *some* good right away. Morphing bug. 


Note: bug#590345 filed to track creating new 10.6 xserve ref image
Summary: Setup recycled bm-xserves as 10.6 build slaves in production → Setup recycled bm-xserves as 10.5 build slaves on TryServer

Comment 5

8 years ago
Created attachment 473748 [details] [diff] [review]
add bm-xserve{08,10,20} to mpt puppet manifest
Assignee: nobody → bear
Attachment #473748 - Flags: review?(bhearsum)
Attachment #473748 - Flags: review?(bhearsum) → review+

Comment 6

8 years ago
Comment on attachment 473748 [details] [diff] [review]
add bm-xserve{08,10,20} to mpt puppet manifest

commited as changeset 55b8823deffc
Attachment #473748 - Flags: checked-in+

Updated

8 years ago
Assignee: bear → nobody
Depends on: 609725
Summary: Setup recycled bm-xserves as 10.5 build slaves on TryServer → Setup recycled bm-xserve08,10,20 as 10.5 build slaves on TryServer
Depends on: 609741
Summary: Setup recycled bm-xserve08,10,20 as 10.5 build slaves on TryServer → Setup recycled bm-xserve08,10,20,23,24 as 10.5 build slaves on TryServer

Comment 7

8 years ago
taking bug to see if they can be quickly added to staging pool.

1. check to see if puppet is creating a proper build environment
2. if yes, move to try
3. if not, fix
Assignee: nobody → bear
Whiteboard: [hardware][buildduty] → [hardware][buildslave][triage]
(In reply to comment #7)
> taking bug to see if they can be quickly added to staging pool.
> 
> 1. check to see if puppet is creating a proper build environment
> 2. if yes, move to try
> 3. if not, fix

Any news?

Comment 9

8 years ago
completely dropped this thru the Tegra cracks - bouncing to buildduty (aka coop) as he is hip-deep in other machine fixes
Assignee: bear → coop
(Assignee)

Updated

8 years ago
Depends on: 620948
(Assignee)

Comment 10

8 years ago
Created attachment 502087 [details] [diff] [review]
Add bm-xserve[08,10,20,23,24] to the list of available slaves
Attachment #502087 - Flags: review?(lsblakk)
Comment on attachment 502087 [details] [diff] [review]
Add bm-xserve[08,10,20,23,24] to the list of available slaves

+TRY_XSERVES    = ['bm-xserve%02i' % x for x in [8,10,20,23,23]]

needs a 24 as the last digit, r+ with that change
Attachment #502087 - Flags: review?(lsblakk) → review+
(Assignee)

Comment 12

8 years ago
Comment on attachment 502087 [details] [diff] [review]
Add bm-xserve[08,10,20,23,24] to the list of available slaves

>+TRY_XSERVES    = ['bm-xserve%02i' % x for x in [8,10,20,23,23]]

Fixed.

https://hg.mozilla.org/build/buildbot-configs/rev/3a173e65bd43
Attachment #502087 - Flags: checked-in+
(Assignee)

Updated

8 years ago
Whiteboard: [hardware][buildslave][triage] → [hardware][buildslave]
fyi: while moving bm-xserve10 around in colo, nthomas discovered that bm-xserve10 is not in DNS. Maybe its still using it's old name "fx-mac-1.9-slave02"  ?
(Assignee)

Comment 14

7 years ago
Created attachment 507496 [details] [diff] [review]
Add bm-xserve[08,10,20,23,24] to the scl puppet slave config.

These slaves live in scl, so I'm assuming they should be talking to the scl puppetmaster.
Attachment #507496 - Flags: review?(dustin)
There are no xserves in Internap (scl1)

I believe these moved from 16 to 14 at MPT (sjc1)
Comment on attachment 507496 [details] [diff] [review]
Add bm-xserve[08,10,20,23,24] to the scl puppet slave config.

A check of DNS and IPs confirms Zandr's comment.

Also, your patch has type application/octet-stream.
Attachment #507496 - Flags: review?(dustin) → review-
(Assignee)

Updated

7 years ago
Attachment #507496 - Attachment is obsolete: true
Attachment #507496 - Attachment is patch: true
Attachment #507496 - Attachment mime type: application/octet-stream → text/plain
(Assignee)

Comment 17

7 years ago
Created attachment 507551 [details] [diff] [review]
Add bm-xserve[23,24] to the mpt puppet config
Attachment #507551 - Flags: review?(dustin)
Attachment #507551 - Flags: review?(dustin) → review+
(Assignee)

Comment 18

7 years ago
Comment on attachment 507551 [details] [diff] [review]
Add bm-xserve[23,24] to the mpt puppet config

https://hg.mozilla.org/build/puppet-manifests/rev/6f5aa3e45a5a
Attachment #507551 - Flags: checked-in+
(Assignee)

Comment 19

7 years ago
These are all connected to pm02 now and are accepting jobs.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Priority: P4 → P2
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Depends on: 629511
Three of these (bm-xserve10, bm-xserve20, bm-xserve24) did not have try keys - fixed in bug 629530.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.