improve tab ordering upon opening and selection upon closing

RESOLVED DUPLICATE of bug 530203

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 530203
8 years ago
4 years ago

People

(Reporter: fryn, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
The main problem that we should fix is the following common case:

1. Start with at least 2 tabs, and select tab 1.
2. Ctrl/Cmd+click a link, or right-click the link and click 'Open Link in New Tab'.
3. With the default settings, the link is opened in a new background tab.
4. Switch the newly created tab.
5. Check out the super cool content on the tab.
6. Close the tab.
7. The tab to the right is selected, instead than the tab from which the link opened.

I wrote up a document with pseudocode to describe the improved behavior we want. It will be linked as the bug's related URL above, while it doesn't go out-of-date.
(Reporter)

Updated

8 years ago
Assignee: nobody → fyan
(Reporter)

Updated

8 years ago
Blocks: 565515
(Reporter)

Updated

7 years ago
Depends on: 533232
(Reporter)

Updated

7 years ago
Depends on: 530203
(Reporter)

Updated

7 years ago
Summary: improve tab hierarchy and selection upon closing tab → improve tab ordering upon opening and selection upon closing
The specific case in comment 0 will be fixed by bug 533232.

The extended case of what happens when you do this for multiple tabs (opened without focus) can be dealt with here.

FWIW, in the past, we've leaned towards a philosophy of "least surprise" which means that unless we can pick behaviour that matches user expectations, we should do nothing and behave consistently. This led to the behaviour where when a new tab opens with focus, it remembers its parent and returns to it on close, but as soon as focus switches to another tab, we dispose that history. It's not perfect, but it's consistent and predictable.
(Reporter)

Updated

7 years ago
(Reporter)

Updated

7 years ago

Comment 2

7 years ago
Check out what Tab Utilities has implemented. On closing the current tab, we can switch to child tabs first if any, then sibling tabs if any, then the parent tab. Tab switching won't lose the parent-child relationship.
(Reporter)

Updated

5 years ago
Assignee: fryn → nobody
Status: ASSIGNED → NEW

Updated

5 years ago
Duplicate of this bug: 823937
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530203
You need to log in before you can comment on or make changes to this bug.