Closed Bug 578609 Opened 12 years ago Closed 12 years ago

Add-on builder creates .xpis with spaces in version number, which AMO rejects

Categories

(Mozilla Labs Graveyard :: FlightDeck, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wenzel, Unassigned)

Details

When I built my "Copy ShortURL" add-on, I obviously saved it occasionally in the Add-on Builder. This results in a version number along the lines of "1.0 rev 12".

When I download the xpi and take it to AMO, it is rejected because of spaces in the version number. Bummer.

I am guessing, the add-on builder should not create such numbers (is 1.0r12 a valid version on AMO instead?), but I am also CCing fligtar in case AMO needs to become more lenient.
afaik, the only validation of versions AMO does is disallowing spaces. This is based on the Toolkit versioning spec ( https://developer.mozilla.org/en/Toolkit_version_format ) which requires that version parts be separated by dots.

I'd rather not start allowing spaces on AMO.
I agree, this isn't an AMO issue.  FlightDeck should generate versions that are valid per the toolkit version format specification.

This seems like a duplicate of bug 580433 (or the other way around).  If so, the workaround is to specify the version yourself in the Edit Info dialog (and then make sure to save the change by pressing the Save button).
http://github.com/zalun/FlightDeck/commit/33bd60d9bcdeb7e8b3c0fdf460e56ace3ebe5f44

returns version_name if specified or latest version.rev# where # is revision number
No longer blocks: 578542
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.