.xpi provided by the Addons Builder supplies a bogus version string in install.rdf

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: crowderbt, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
My install.rdf contains the following version tag, which is rejected by AMO:

<em:version>copy rev. 20</em:version>
I see this too.  It looks like the builder inserts a value like the one you are seeing into the <em:version> element of the install.rdf file when you haven't specified a version for your addon by clicking the name of your addon in the editor interface and typing the version into the Version field of the Edit Info dialog box.

It's great that the builder automatically specifies a version rather than making you specify one, but it should specify a valid version, such as "1.0", which is the version that the SDK specifies if the developer doesn't specify one.

In the meantime, the workaround is to specify the version yourself via the Version field of the Edit Info dialog.
(Reporter)

Comment 2

8 years ago
Myk:  This workaround does not actually work around the issue.  If I specify a version string in the Edit Info dialog, the version that ends up in my .xpi is this:

    <em:version>0.2 rev. 20</em:version>

(ie., "0.2" which is the rev I specified in the edit info, replaces the "copy" from before.)
(Reporter)

Comment 3

8 years ago
Actually, I may have run into trouble with this for a different reason.  Disregard comment #2, please.
This could be a dupe of bug 578609.

Brian: were you able to use the workaround in the end?
Note: I think you need to press the Save button after specifying the version in the Edit Info dialog.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Component: FlightDeck → FlightDeck
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.