Unknown content type handler dialog needs override capability

VERIFIED DUPLICATE of bug 90538

Status

()

Core
Embedding: APIs
P3
normal
VERIFIED DUPLICATE of bug 90538
18 years ago
17 years ago

People

(Reporter: Judson Valeski, Assigned: Chak Nanga)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Embedding applications need the ability to provide their own unknown content
type dialog. I suspect this means that we need a new interface,
nsIUnknownCTypeDialog or something, which the embeddor implements (the impl
throws UI). Based on the return values in the callbacks, we'll take appropriate
action.

Obviously I haven't fleshed this out.
(Reporter)

Updated

18 years ago
Keywords: embed

Comment 1

18 years ago
Updating QA Contact
QA Contact: jrgm → mdunn
(Reporter)

Updated

17 years ago
Blocks: 70229
(Reporter)

Updated

17 years ago
Keywords: embed → mozilla0.9.1

Comment 2

17 years ago
Correction: Changing QA contact for the Embed API bugs to David Epstein.
QA Contact: mdunn → depstein
(Reporter)

Comment 3

17 years ago
-> chak. this *might* be done already.
(Reporter)

Comment 4

17 years ago
-> chak for real.
Assignee: mscott → chak
(Assignee)

Comment 5

17 years ago
We can now override the unknown content type handler dialogs by the fix checked
in as part of #90538

*** This bug has been marked as a duplicate of 90538 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
verifying as dup of 90538
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.