linebreak in url -> browser requests truncated url

VERIFIED DUPLICATE of bug 57968

Status

()

Core
Layout
P3
minor
VERIFIED DUPLICATE of bug 57968
17 years ago
16 years ago

People

(Reporter: Jens Schiffler, Assigned: Eric Pollmann)

Tracking

Trunk
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [de] (OS/2; U)
BuildID:    2000102005

This badly coded page has some urls in it that are formatted with 
linebreaks. When clicking on such a link, mozilla obviously requests 
only the first line of the url, resulting in the wrong page beeing 
shown.

I understand that this may be not a real mozilla bug but a bug in their 
html code, but other browsers (Netscape, IE) cope with it.

Reproducible: Always
Steps to Reproduce:
1. Open page http://www.mint-data.de/cgi-bin/mint/shop.cgi?d=hdd
2. Select the link "Atapi" 



Actual Results:  the same page is loaded again

Expected Results:  a page showing a catalog of atapi drives should be 
loaded

Comment 1

17 years ago
Confirmed in Mac OS 10-24 branch.  However, I'm tempted to out in KW: evangelism.  
In the interest of neat code (and those guys code is very organized!) I'd like to 
see this one fixed-any spaces or new line characters should be stripped away...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Hardware: PC → Macintosh
Reassigning to pollmann. Eric, this is similar to the other linefeed stripping
issues your looking at. 
Assignee: clayton → pollmann
(Assignee)

Comment 3

17 years ago
Yes, it's a duplicate.  Marking as such.  Thanks!

*** This bug has been marked as a duplicate of 57968 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.