Closed Bug 579109 Opened 11 years ago Closed 11 years ago

[faceted search] Last search result display format should be remembered and used (option to skip faceted results, remember "open as list")

Categories

(Thunderbird :: Search, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 518336

People

(Reporter: jhopkins, Unassigned)

Details

Message search results in Thunderbird are presented via an interface that lets you filter by people, folders, etc...  On that page there's an option to "Open as list" which presents a typical multi-column table of results.

Thunderbird should remember what search result view I prefer (the one I used last) and default to showing results in that format the next time I search.  That would save me from having to click "Open as list" every time I search mail (since I prefer that view).
isn't this a duplicate?
Whiteboard: dupme
XREF Bug 580252 - Search: Option to make "Open as List" view the default view
XREF Bug 518336 - Bug 518336 - [faceted search]: Move "Open as list" button to the top-left of search results to toggle showing listview + oldstyle msg preview on the right of same tab

These are all slightly different in terms of the envisioned UI/behaviour, but underlying wish is the same: a way of skipping fancy faceted results in favor of the plain list. I'd love that, too.

Wayne, Bug 518336 had "Show all as list" in the summary before I tweaked it right now, which btw I think is better wording than "Open as list" as we are not opening messages
Summary: Last search result display format should be remembered and used → [faceted search] Last search result display format should be remembered and used (option to skip faceted results, remember "open as list")
>> Wayne, Bug 518336 had "Show all as list" in the summary before I tweaked it
right now, which btw I think is better wording than "Open as list" as we are
not opening messages

Some other possibilities: "View as List", "List View", "Grid View"
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 528044
Per its summary and comment 0, this is clearly NOT a duplicate of bug 528044.

This bug 579109 wants to remember which result mode the user prefers: either fancy faceted results mode, or "open as list" mode. So it's about a not very clearly defined way of skipping the first faceted results screen if user prefers "open as list" mode, or vice versa. Cf. comment 0:

> That would save me from having to click "Open as list" every time I search
> mail (since I prefer that view).

Bug 528044 wants to remember, only *within* "open as list" mode, the columns that user picks from column picker.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #0)

John, the expected behaviour of this bug is not very clear (see below). Please rewrite comment 0 and stick to the following scheme of filing bugs:

- steps to reproduce (STR)
1) do this
2) do that
3) ...
- actual behaviour
   - what happens in the current version
   - and more...
- expected behaviour
   - what should happen instead, in your opinion
   - and more


> Thunderbird should remember what search result view I prefer (the one I used
> last) and default to showing results in that format the next time I search. 
> That would save me from having to click "Open as list" every time I search mail
> (since I prefer that view).

The expected behaviour is not clear, because when you use "open as list" at all, it will always be the "last used" mode due to the current design. So how do you expect TB to know if you prefer (or not) to skip the "fancy faceted results" (my terminology for the first results screen with mini previews)?

Some options to determine "preference for list mode" might be
- time: if user clicks on "open as list" within less than 3 secs from seeing the fancy results
- no clicks on message titles from fancy results, but then: what if user chose some fancy facets first?
- no clicks nowhere on fancy facets or results, click on "open as list" straight away
- ?
Even if we find a good criterion, will it be transparent for the user what's going on?

John, please consider if/how your problem could be addressed by any of bug 580252 or bug 518336.
1) Perform a search
2) Get a set of results back in faceted results format
3) Click "Open as List" to change to a columnar results format
4) Perform another search
5) See #2

Expected: Thunderbird remembers that I last used the List format.
Actual: Thunderbird continues to present results in Faceted format.

This request is not the same as the other bugs referenced in comment 6 (though similar in intent to bug 580252) because I'm asking for Thunderbird to remember what I last used, not to set a default somewhere.
Implementation suggestion: When clicking "View as List", do not open a new tab.  Instead, simply display the results in the same tab using the requested results format (List).  Then the link changes to "View Faceted" so the user can toggle between formats at will.

This is similar in concept to how a file manager can present a file listing differently (as a list or thumbnails) and remember the last view used.  You don't see a file manager opening a new tab with a different view style.  When you can use an existing paradigm that works, I think it's a good idea to.
John, thanks for clarifying.

(In reply to comment #7)
> Expected: Thunderbird remembers that I last used the List format.

In the /current/ design, comment 7 alone means that you'll never see the fancy faceted results again (and have no way of returning it) if TB remembers that you once used "Open as list". It only works in combination with something like comment 8:

(In reply to comment #8)
> Implementation suggestion: When clicking "View as List", do not open a new tab.
> Instead, simply display the results in the same tab using the requested
> results format (List).  Then the link changes to "View Faceted" so the user can
> toggle between formats at will.
> This is similar in concept to how a file manager can present a file listing
> differently (as a list or thumbnails) and remember the last view used.

Exactly, sounds good. John, where is the difference to bug 518336? That bug wants exactly that (a toggle button for the two different views), only that they propose moving the toggle button to the top of the left pane with the facets. So the facets pane on the left stays, while the views change in the bigger message list pane on the right. Is that what you want?

--> I propose duplicating this bug against bug 518336.

Otherwise, please explain your UI, especially where you want to keep the button in the grid-style view, by attaching a mockup screenshot of your proposal.
Thanks, Thomas.  I suppose this bug is similar enough to 518336 to warrant a duplicate designation.  The only significant difference between the two is I want the last search results setting remembered so I don't have to toggle to list view each time I search.
(In reply to comment #10)
I'll add a comment in bug 518336 that we need to remember the search results view mode, which I actually took for granted, but then, you never know...
Let's first focus on /getting/ the toggle button of bug 518336, as requested by this bug...

-> duplicate of bug 518336

I'm not overly happy with the UI in bug 518336 - do we need the fancy left pane with the facets when in list mode? However, I can't quite picture anything better. If you can, please contribute your UI ideas in bug 518336.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
OS: Windows 7 → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 518336
You need to log in before you can comment on or make changes to this bug.