Closed Bug 579321 Opened 9 years ago Closed 9 years ago

Always Ask for Add-ons Broken

Categories

(Toolkit :: Add-ons Manager, defect, major)

defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 553503

People

(Reporter: grizzly, Unassigned)

Details

(Whiteboard: [AddonsRewrite])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

I have my preferences set to always ask to install updates to add-ons. Today, I opened Firefox and NoScript was updated to v1.10 without any prompt or notification that it was updated. The only way I knew that it happened is that when updating NoScript, the update takes you to the NoScript homepage.

Reproducible: Didn't try




This is the first time I noticed this behavior. There is no way to tell if other add-ons have been updating without my permission. They may have been updating all along, without my knowledge.
Version: unspecified → Trunk
Component: Preferences → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: preferences → add-ons.manager
Related with bug 571527 and/or bug 562622 ?
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [AddonsRewrite]
What preference are you referring to?
What preference are you referring to?

Tools->Options->Advanced->Update->When updates to Firefox are found: Ask me what i want to do.

Does this no longer cover updates to Add-ons? If so, I would like to see it return to the previous configuration to cover Add-on updates as well as Firefox itself.
It never covered updates for add-ons... only updates to Firefox. It also provides the option to update Firefox silently when all add-ons that are currently compatible are compatible with the update to Firefox or the incompatible add-ons have updates available that are compatible with the update to Firefox.
I'm going to dupe this to bug 553503 as it will cover whatever we do along these lines.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553503
Status: RESOLVED → VERIFIED
Related with bug 571527 and/or bug 562622 ?

It's related to 562622. I didn't realize that the preference only related to Firefox itself in past versions. I read through 562622 and realize it's getting ironed out. I feel that there should be a prompt if the user wants one. If an update to an add-on breaks something, the user should be allowed to opt-out of the update until it gets fixed. I ran into a similar situation with Coral IE Tab in SeaMonkey and had to skip a version until it was fixed.
You need to log in before you can comment on or make changes to this bug.