Last Comment Bug 571527 - Add pref default for automatic vs. ask-me add-on update
: Add pref default for automatic vs. ask-me add-on update
Status: RESOLVED FIXED
[AddonsRewriteTestday][AddonsRewrite]
:
Product: SeaMonkey
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: All All
: -- enhancement with 1 vote (vote)
: seamonkey2.1b3
Assigned To: rsx11m
:
Mentors:
Depends on: 562622 586574 606482
Blocks: SMAddonMgr 641252
  Show dependency treegraph
 
Reported: 2010-06-11 10:15 PDT by Tony Mechelynck [:tonymec]
Modified: 2011-03-15 13:12 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposed patch [Checkin: comment 16] (2.63 KB, patch)
2011-03-15 05:04 PDT, rsx11m
neil: review+
Details | Diff | Review

Description Tony Mechelynck [:tonymec] 2010-06-11 10:15:52 PDT
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100610 SeaMonkey/2.1a2pre

(Maybe wait until bug 562622 will have landed) Add pref in "Edit => Preferences => Advanced => Software Installation" to switch all extensions from "Update automatically" to "Ask me" or vice-versa, similarly to what is already done for SeaMonkey. This is the SeaMonkey counterpart (or maybe a complement) of bug 562622 comment #4 point 2 (IMHO in SeaMonkey the UI should exist not only in the new add-on manager (which hasn't got it yet) but also next to where very closely related prefs live in SeaMonkey's Preferences.
Comment 1 Jens Hatlak (:InvisibleSmiley) 2010-09-14 01:11:54 PDT
The minimum is to simply add the new extensions.update.autoUpdateDefault pref to browser-prefs.js.
Comment 2 Robert Kaiser (not working on stability any more) 2010-09-14 05:02:40 PDT
For the UI, the new add-ons manager now has it, but it might be a good idea to reorganizer the updates sections of the software installation prefs dialog into application and add-ons groups, and make the add-ons group have that pref as well.
Comment 3 Justin Wood (:Callek) 2010-09-14 16:14:22 PDT
(In reply to comment #2)
> For the UI, the new add-ons manager now has it, but it might be a good idea to
> reorganizer the updates sections of the software installation prefs dialog into
> application and add-ons groups, and make the add-ons group have that pref as
> well.


Neil, [as ui tsar] do you have a preference on if and where we expose this pref in our UI?

I'm partial to only in addon manager itself, (or that plus update pane of prefwindow) but whatever you choose, we can get it done.
Comment 4 Robert Kaiser (not working on stability any more) 2010-09-14 18:22:56 PDT
I wondered a bit, but I think what bug 595744 removes from the add-on manager itself isn't the "update automatically" pref but just one to search for them...
Comment 5 neil@parkwaycc.co.uk 2010-09-29 13:23:42 PDT
So this new pref is the addon counterpart to the app.update.auto pref? If so then yes I think it would be reasonable to add it to the Software Update pane. You'd probably need to reorganise the pane a bit though.
Comment 6 rsx11m 2011-03-14 11:08:39 PDT
Is this bug still applicable after the bug 606482 redesign of that pane?

  [ ] Allow websites to install add-ons and updates
      [ ] Automatically check for updates ( ) daily ( ) weekly
          [ ] Automatically download and install the updates

The last option seems to be what's asked for here.
Comment 7 Jens Hatlak (:InvisibleSmiley) 2011-03-14 11:24:19 PDT
As you can see from looking at pref-smartupdate.xul, we now have all relevant extensions.update.* prefs in the UI. What's missing is what I wrote in comment 1: We have only have .enabled, .url and .interval in browser-prefs.js, but not yet .autoUpdateDefault. Cf. http://mxr.mozilla.org/comm-central/source/mozilla/browser/app/profile/firefox.js#76 (haven't checked in the back-end what the default is, but I for one think it's bad to have something in the UI but not about:config).

Go for it!
Comment 8 rsx11m 2011-03-14 11:58:09 PDT
Searching for it in toolkit appears to confirm that a backend is present for the extensions.update.autoUpdateDefault preference, thus the only item left is to set a default value in suite/browser/browser-prefs.js matching Firefox's?
Comment 9 Jens Hatlak (:InvisibleSmiley) 2011-03-14 12:38:59 PDT
(In reply to comment #8)
> Searching for it in toolkit appears to confirm that a backend is present for
> the extensions.update.autoUpdateDefault preference, thus the only item left is
> to set a default value in suite/browser/browser-prefs.js matching Firefox's?

Yes, as I had guessed and confirmed now, the Add-on Manager back-end ensures the pref is true by default, but we should really provide a default pref in browser-prefs.js to have consistency between UI and about:config.
Comment 10 rsx11m 2011-03-14 13:12:33 PDT
Looking at bug 586574 which implemented that preference, it is not clear to me if there is an "extensions.{GUID}.update.autoUpdateDefault" override of the default for specific extensions as well. If yes, it can probably go along with the ".{enabled,url,interval}" prefs, otherwise it should be rather separate.
Comment 11 neil@parkwaycc.co.uk 2011-03-14 14:46:16 PDT
(In reply to comment #10)
> Looking at bug 586574 which implemented that preference, it is not clear to me
> if there is an "extensions.{GUID}.update.autoUpdateDefault" override of the
> default for specific extensions as well. If yes, it can probably go along with
> the ".{enabled,url,interval}" prefs, otherwise it should be rather separate.
The {GUID} is a placeholder. The actual GUID depends on the extension. So for instance, if you wanted to stop automatically updating the debugQA extension, you could set extensions.debugQA@mozilla.org.update.autoUpdateDefault to true.
Comment 12 Justin Wood (:Callek) 2011-03-14 20:27:45 PDT
(In reply to comment #8)
> Searching for it in toolkit appears to confirm that a backend is present for
> the extensions.update.autoUpdateDefault preference, thus the only item left is
> to set a default value in suite/browser/browser-prefs.js matching Firefox's?

Correct.
Comment 13 rsx11m 2011-03-15 05:04:10 PDT
Created attachment 519381 [details] [diff] [review]
Proposed patch [Checkin: comment 16]

Thanks for the input. I've added the pref to the {GUID} block per comment #11. The Software Installation settings now show "Automatically download and install the updates" correctly checked by default with a new profile. This patch also tries to improve the inline comments of the preferences a bit.
Comment 14 neil@parkwaycc.co.uk 2011-03-15 05:16:36 PDT
Comment on attachment 519381 [details] [diff] [review]
Proposed patch [Checkin: comment 16]

Hmm, well I don't know what they mean by "symmetric" here but it looks OK.
Comment 15 rsx11m 2011-03-15 05:19:15 PDT
Yeah, I was a bit confused by that too, but I figured that whoever wrote it that way had an idea how it's called, thus didn't touch it.  ;-)

Thanks for the quick review, push for comm-central please.
Comment 16 Jens Hatlak (:InvisibleSmiley) 2011-03-15 13:11:47 PDT
Comment on attachment 519381 [details] [diff] [review]
Proposed patch [Checkin: comment 16]

http://hg.mozilla.org/comm-central/rev/063b5457a683

Note You need to log in before you can comment on or make changes to this bug.