Last Comment Bug 579372 - "Search within message" impossible on MacOS due to horrific "Quick Filter"
: "Search within message" impossible on MacOS due to horrific "Quick Filter"
Status: VERIFIED DUPLICATE of bug 564328
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: All Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-16 10:05 PDT by Richard Mlynarik
Modified: 2011-07-13 20:49 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Richard Mlynarik 2010-07-16 10:05:05 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

Command-F, typed when focus is on the message display pane, no longer works to search for a string within the message body.

Instead it pops up the horrifically badly implemented, screen real estate eating, maximally irritating, clearly untested on MacOS and insanely inconsistent UI "Quick Filter" bar.

Judging by what I see under the "Edit / Find / Find in this Message" menubar,
somebody appears to have had the bright idea of assigning the command-G
keyboard shortcut to this useful function.

But that DOESN'T WORK because command-G is also bound to
"Edit / Find / Find Again"
(Well, it works once.  But doesn't work the second time.)

Can we please JUST GET RID OF THE GODAWFUL "Quick Find toolbar" NONSENSE ASAP?????  What an unmitigated mess!


Reproducible: Always

Steps to Reproduce:
1. Select message body pane
2. Type Command-F and a search string
3. Message body is searched, just as it has been for the last, oh, 15 years
Actual Results:  
Utterly worthless stupid "Quick Search" bar pops up, and then subsequently typed
characters (the things I thought would be the search string, based on, oh, 15 years of consistency of UI) END UP BEING INTERPRETED AS COMMAND KEY SHORTCUTS
and random actions are performed by Thunderbird

Expected Results:  
Command-F = search.

DEATH TO THE HOPELESS AND NEVER TESTED "Quick Search" JUNKBAR.


Does anybody even think before dumping these "features" into a mostly working product?

Argggh.
Comment 1 Mark Banner (:standard8, limited time in Dec) 2010-07-19 01:13:20 PDT
Doing Command-G will take you straight to the search again within this message.

Doing Command-F will take you to the quick search for the folder, doing a second Command-F will then take you to the quick search within the message.

Whilst this change will take a bit of getting used to, we feel it is for the better all round.

I don't see us removing the quick search bar as it was a solution to another issue, and has been well received as it also gives much better capabilities that the old version of quick search. Therefore marking as won't fix.
Comment 2 Richard Mlynarik 2010-07-21 12:48:17 PDT
You know, every time I see a comment from Mark "WONTFIX" Banner I just want to reach out through the intertubes and cut off his damned fingers to prevent him ever writing any code -- or worse, writing "specifications" that define bugs out of existence -- ever again.

I'm the user.  DON'T TELL ME THAT MY BUGS DON'T HAPPEN.

People like you are why free software is completely doomed, and why I (the second person after Stallman to ever write any GNU code) gave up a decade ago.

Seriously, screw you.

For anybody other than ":standard8" here's the objective, reproducible, user experience deal:

1. You broke command-F.
It worked for decades.  It was consistent with the UI of pretty much every other program on the platform.  Now it isn't.  Well done.

2.  You "substituted" command-G.
This is inconsistent with pretty much every other program on the platform.
Command-G means "search again".

And the kicker: ****** COMMAND-G DOES NOT WORK ********

Repeat D.O.E.S. N.O.T. W.O.R.K.  Got that?


No matter how often good old :standard8 declares bugs "WONTFIX" this doesn't change.

Try it and see.  Just for once.

Seriously, screw you.
Comment 3 Dan Mosedale (:dmose) 2010-07-21 16:33:31 PDT
Because Thunderbird is a community effort, it's very important to us that it be an enjoyable place to get work done, even when that work involves making decisions that some people disagree with.  Every time a developer sees posts like the above, it makes Thunderbird feel like a less pleasant place to work, which results, over time, in us losing talented developers (I've seen this happen _far_ too many times over the years).

I appreciate that changes to existing software like Thunderbird are sometimes frustrating.  This is entirely valid, and there are a variety of places where one can express these feelings (in the Thunderbird context, GetSatisfaction is probably the best outlet for these feelings).  Note, however, that posts as uncivil as the above are not welcome in _any_ Thunderbird community.

Please consider how you would feel if someone reacted as you did above to something that you had worked hard on and review <https://bugzilla.mozilla.org/page.cgi?id=etiquette.html> before posting to Bugzilla again.
Comment 4 Brendan Eich [:brendan] 2011-07-08 23:57:16 PDT
I'm late to this party, but ignoring major etiquette violations, I agree with Richard's complaints if they are accurate (I have not used Thunderbird in years -- long story, not for this bug):

1. cmd-F is Find in message in Mail.app, find in page in Firefox, etc.

2. cmd-G works only once, not again, if I'm reading Richard right.

Isn't 2 a bug even if 1 is WONTFIX?

It's easy to let bad behavior induce throwing out good content in the bug report with bad. We should avoid that here. Is this really WONTFIX? Even if so, what about item (2)?

/be
Comment 5 gatopeich 2011-07-09 14:29:18 PDT
I agree with Richard, and sympathize with his excess against the 'geekiquette'.

Giving the user such an answer can be a worse insult than a "screw you". There are levels in the communication, and not all insults are so obvious.

I am also a bit annoyed by the _non-standard_ behavior of Ctrl-F, even after I deliberately click within the message text to try to be in that context. I have to workaround it by opening the message in a new window/tab. 99% of the times I don't want any "Quick search" and when I do I don't expect to have a shortcut for it. Not Ctrl-F for sure.

As an user, no 'talented' developer is convincing me that a standard shortcut needs to do a different thing in this specific app. If I have to stand many more random usability issues I will eventually just switch to other app with less of them.

As a coder, I had a good laugh with Richard's rant, maybe because I have felt exactly the same in other opensource projects, and because I can't fancy myself accused of insulting a user's intelligence like that.

If you care about users, give us back our _standard_ Ctrl-F functionality and find another shortcut for your beloved "quick search" (Ctrl-Shift-F?), though I've never felt the need of a shortcut for it.

At any rate, thanks for maintaining Thunderbird.
Comment 6 Blake Winton (:bwinton) (:☕️) 2011-07-09 14:42:05 PDT
(In reply to comment #4)
> 2. cmd-G works only once, not again, if I'm reading Richard right.
> Isn't 2 a bug even if 1 is WONTFIX?

This bug isn't a good place for any actual work to happen, even if #2 was a bug, but since Cmd-G works just fine on my Mac, I don't think there's any point in filing a new bug, or attempting to re-open this bug.

> 1. cmd-F is Find in message in Mail.app, find in page in Firefox, etc.

I agree that Cmd-F is Find, but I believe that Thunderbird has a different enough context from Firefox that the mapping you suggest isn't quite the right one.  I'll be in Mountain View next week, if you want to schedule a meeting with me, I'ld be happy to discuss the various options we've considered, and why we went with the option we did.

Thanks,
Blake.
Comment 7 Brendan Eich [:brendan] 2011-07-09 20:54:28 PDT
(In reply to comment #6)
> (In reply to comment #4)
> > 2. cmd-G works only once, not again, if I'm reading Richard right.
> > Isn't 2 a bug even if 1 is WONTFIX?
> 
> This bug isn't a good place for any actual work to happen, even if #2 was a
> bug, but since Cmd-G works just fine on my Mac, I don't think there's any
> point in filing a new bug, or attempting to re-open this bug.

Anyone else see the problem comment 0 talks about here?

> > 1. cmd-F is Find in message in Mail.app, find in page in Firefox, etc.
> 
> I agree that Cmd-F is Find, but I believe that Thunderbird has a different
> enough context from Firefox that the mapping you suggest isn't quite the
> right one.  I'll be in Mountain View next week, if you want to schedule a
> meeting with me, I'ld be happy to discuss the various options we've
> considered, and why we went with the option we did.

No, I don't see a falsifiable theory here, so I don't think it would be a good use of anyone's time.

You deviated on something basic all other apps, especially mail user agents, especially Thunderbird in past releases, did and do. That might be a breakthrough, but I doubt it. It looks like anti-leverage, bound to break muscle memory and annoy users who care, while not particularly being discoverable and beneficial to those who do not care. Next time, use a different shortcut.

/be
Comment 8 Blake Winton (:bwinton) (:☕️) 2011-07-09 21:29:54 PDT
I've managed to convince someone else who originally thought that it was the wrong decision that the new behaviour is better, so I suspect I could also change your mind, but I'm equally happy to not spend the time trying.  :)

And for the record, I wasn't involved in making the decision.  I just believe it to be the best choice, even taking into account the serious disadvantage you list.

Thanks,
Blake.
Comment 9 Brendan Eich [:brendan] 2011-07-09 21:48:15 PDT
(In reply to comment #8)
> I've managed to convince someone else who originally thought that it was the
> wrong decision that the new behaviour is better, so I suspect I could also
> change your mind, but I'm equally happy to not spend the time trying.  :)

Since you replied, I'm going to make a point independent of your faith in the decision being right (I already made it in comment 7, but one more try).

You broke users' muscle memory and cross-app usability tolerance. You believe something is better. But you're in win/lose land, at best, and trying to "convince" people. That's lose-lose-lose in my book. You never "convince" people, you make kick-ass UI that doesn't bite back. You use another shortcut than cmd-F for your new and great invention.

/be
Comment 10 Eric Fitton 2011-07-10 10:00:16 PDT
If your email client is intended to be for developers and by developers why did you choose to brand with Mozilla? If your email client is intended for users, why are you treating normal users like ****? (Look at But 478468 if breaking command-F isn't enough).

I have used Thunderbird on and off for a long time. Mostly off to be honest. I was thinking of installing it again and giving it another whorl. Not now, not ever. Command-F means find in the appropriate context. Not hitting it twice and getting different behavior which is beyond bizarre. Not popping up a dialog box and then not entering the search string. Anything other than Find is broken in my mind.

I am a teacher. I use software to get stuff done. I am willing to spend no time on tutorials and no time installing extensions. If I install an email client I expect to spend about 5 minutes getting my pop settings to my liking, including leaving messages on the server for x days so I can also check my accounts with webmail. Then I expect to be able to read and send email. How would someone like me ever figure out your, frankly bizarre, search procedures? Why would I care if I did manage to figure it out? I spend most of my time doing things other than email. If you want crazy configuration files for power mailers, go for it. But I expect a low learning curve, for the software to work, get out of my way and be consistent with the rest of my environment.
Comment 11 gatopeich 2011-07-11 00:20:08 PDT
(In reply to comment #10)
> If your email client is intended to be for developers and by developers why
> did you choose to brand with Mozilla? If your email client is intended for
> users, why are you treating normal users like ****? (Look at But 478468 if
> breaking command-F isn't enough).

Don't waste your breath, Eric. We don't have a [:dev-nick] so we just don't exist here. We are just two of those 'users' that developers some times talk about but have never seen.
Comment 12 Brendan Eich [:brendan] 2011-07-11 10:09:19 PDT
Blake, are you standing by this WONTFIX?

/be
Comment 13 Blake Winton (:bwinton) (:☕️) 2011-07-11 17:08:47 PDT
No, (see https://bugzilla.mozilla.org/show_bug.cgi?id=564328#c135 for my current thinking,) but I _would_ rather do the work in Bug 564328, since it has more context, and better information.

Does that make this bug a dupe of 564328, then, or is it something else, since the summary is incorrect?  (You can search within the message, just not the way the reporter wants to.)
Comment 14 Brendan Eich [:brendan] 2011-07-12 09:21:43 PDT
Yes, dup'ing this to bug 564328 and fixing that one soon sounds good to me.

/be
Comment 15 Blake Winton (:bwinton) (:☕️) 2011-07-13 20:49:50 PDT
Wow, looks like there's even a patch there already…

*** This bug has been marked as a duplicate of bug 564328 ***

Note You need to log in before you can comment on or make changes to this bug.