Last Comment Bug 579533 - Opening feed item in standalone msg window does not honor "article summary" pref
: Opening feed item in standalone msg window does not honor "article summary" pref
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 515790 613690 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-16 14:19 PDT by Ben Bucksch (:BenB)
Modified: 2012-11-20 14:24 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ben Bucksch (:BenB) 2010-07-16 14:19:53 PDT
Reproduction:
1. Change your Thunderbird 3pane to hide the message pane
   via menu View | Layout | [ ] Message Pane or keyboard F8
2. Add an RSS feed
3. Check [x] Show the article summary instead of loading the webpage
   for that feed
4. Double-click on a news item, thereby opening the item
   in a new standalone message window.

Actual result:
The news item loads, but as webpage (http hit to webserver), not the description from the RSS feed.
Downsides:
- Takes 2-3 seconds for many sites
- Gives a ping to the webserver that I read the item
- It's a different layout, that of the webpage, usually more heavyweight,
  while I wanted just the text.

If I enable the message pane, the article summary (not the webpage) loads in the message pane.

Expected result:
The webpage for the news item loads in a standalone message window.

My explicit preferences, namely not to use the message pane but a standalone message window and not to use the webpage but the article summary in the RSS feed, are not honored.

(I realize that behavior is probably intentional by the developer, but it's: )

Importance:
- Clearly violating what the UI says.
- Not honoring (offered) preferences, I don't want a message pane, and
  I want instant, local loads without network hit.
- Load times of the webpages are annoying.
Comment 1 [:Aureliano Buendía] 2010-11-28 08:23:15 PST
*** Bug 515790 has been marked as a duplicate of this bug. ***
Comment 2 [:Aureliano Buendía] 2010-11-28 08:26:47 PST
*** Bug 613690 has been marked as a duplicate of this bug. ***
Comment 3 alta88 2010-11-29 09:36:04 PST
the problem is that since the 'toggle summary/web page' patch was implemented, there is now an overwhelming number of message opening preferences leading to inconsistent/contradictory UI.  pre tabs, the patch did of course honor page/summary prefs in the standalone window, i don't know where it regressed.  one issue is that <enter> on a list item used to open in a window but default is now tab, unless changed.

so, if Options->Advanced->Reading&Display->Open Message in a new or existing window is checked, *and* main window Message->Open Feed Message->Summary is checked, you will get summaries, regardless of the default pref in Subscribe *or* View->Feed Message Body (which overrides the Subscribe pref globally and is meant to apply more usefully to selecting a list item as regards the message pane - ie not standalone message window).

yes, this has become extremely confusing and needs to be streamlined and rationalized.
Comment 4 Leho Kraav (:macmaN @lkraav) 2011-03-13 13:11:54 PDT
i have just run into this and found that messing with about:config settings from bug 513652 comment 9 helped:

> The only way to switch between "website" and "summary" is still to change the
> preference
> rss.show.content-base
> 0: website
> 1: summary

i am now getting summary displayed in a separate window.
Comment 5 alta88 2012-03-06 15:36:58 PST

*** This bug has been marked as a duplicate of bug 728563 ***
Comment 6 Chris 2012-11-20 11:20:25 PST
(In reply to Leho Kraav (:macmaN @lkraav) from comment #4)

Thanks for the hint about "rss.show.content-base" setting. This solved my problem with viewing RSS items in a new tab in TB17.
Comment 7 alta88 2012-11-20 14:24:38 PST
this has been fixed by bug 596234.  standalone follows the View->Feed Message Body as setting.

Note You need to log in before you can comment on or make changes to this bug.