Closed Bug 513652 Opened 10 years ago Closed 8 years ago

RSS-preference "show article summary instead of the website" in the RSS-account-menu doesn't work

Categories

(MailNews Core :: Feed Reader, defect)

1.9.1 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 550800

People

(Reporter: dfghjkjhg, Unassigned)

References

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

It's an old problem which already appeared in TB 2:
The RSS-setting in the account-menu "show article summary instead of the website" doesn't work.
Irrespective of the setting made there, only the website is always displayed.

The only way to change TB's behaviour is to go directly into TB's configuration and change the following value there:

rss.show.content-base
0: website
1: summary

Changing the RSS-preference in the RSS-account-menu ("show article summary instead of the website") doesn't change this configuration value ("rss.show.content-base").

Reproducible: Always
confirming based on https://bugzilla.mozilla.org/show_bug.cgi?id=509913#c7
Status: UNCONFIRMED → NEW
Component: Preferences → Feed Reader
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: preferences → feed.reader
Version: unspecified → 1.9.1 Branch
If you select an rss message then go to View -> Feed Message Body As, does that show "Default" is selected?

If not, select default and then try again.
"Default" wasn't selected (but "Website"). Just changed this to "Default". But doesn't show any impact.
WFM over here.
Not all feed necessarily have any summary of course...
I also have problems viewing the feed properly. The last Version of Thunderbird
properly displaying RSS was 3.0b2. - 3.0b3 and 3.0b4 both have problems.
I use Win XP.

I think this bug is the same as https://bugzilla.mozilla.org/show_bug.cgi?id=505664
Same/similar Thunderbird 3 problem?

Not sure if this is the same thing, but I'm always getting a blank article summary if there's an MP3 attachment for all my podcast feeds. The only way I can see the summary is "view source". This is very annoying!  And for some reason, on opening the message it now launches straight into the download operation. That is also annoying.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Vista SP2 Home premium.
Okay - solved that last MP3 launching issue. Apologies for that.

Still need the blank article summary resolving though.
See Also: → 520034
In TB 3.0 and later, the
  View | Message Body As
menu changes when a feed item is selected, and that lets you change the global RSS-item display mode.

See bug 438429 comment 81.
Just tested the tip from comment#8.
But in fact it doesn't have any impact on the RSS display behaviour. The chosen display format in "View | Message Body As" is totally ignored.

The only way to switch between "website" and "summary" is still to change the preference
rss.show.content-base
0: website
1: summary
If you didn't see the menu item text change to "Feed Message Body As" then you haven't seen what I was talking about.  Not your fault, the implementation of the new menu is pretty faulty.  See bug 550793.
I am sorry, I just took the wrong wording, because I am using a German version of Thunderbird and therefore sometimes I am not aware of its original English menu items/names:

In fact (as you described) the menu text changed from "Message Body As" to "Feed Message Body As" after having selected a RSS feed. Nevertheless its settings do not have any effect.
I see this problem exists in Thunderbird 3.0.4 as well.  As "rosaroter" said, the "Default" selection under "View->Feed Message Body As" does not work, in that it does not reflect the feed type selected in the RSS feed's subscription. In my case, "Default" displays the summary, not the web page.

This is quite annoying to me, as I have many feeds, some of which have decent summaries, some of which do not. I was always able to have Thunderbird 2 display some feeds' summaries and other feeds' webpages. Now it appears I can't do that without manually switching between them on a per-item basis.

Since this bug is a regression from a feature that used to work, its priority should probably be bumped up a bit (unless it's fixed in 3.1RC, which I haven't tried yet).
(In reply to dfghjkjhg from comment #3)
> "Default" wasn't selected (but "Website"). Just changed this to "Default".
> But doesn't show any impact.

the menuitem works.  however, if you have multiple feeds per folder, and have mixed summary and no summary, that is a problem in bug 550800.  if this isn't the case, feel free to submit a new bug.

(In reply to Dave Kirk from comment #7)
> Okay - solved that last MP3 launching issue. Apologies for that.
> 
> Still need the blank article summary resolving though.

there is no guarantee the publisher indicated a link or a link to a valid web page, per the spec.  thus, if you have it set to show web page, you'll see nothing.  in the autoload of an mp3, the publisher said that's the url, which is why when the url is loaded, it downloads the file.  check show summary instead.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550800
You need to log in before you can comment on or make changes to this bug.