HTML iframe can't be panned

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: testit, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

352 bytes, application/zip
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: 

It's not possible to pan the content of an HTML iframe. This worked without problems in Fennec 1.

Tested with Fennec for Windows version 2.0a1pre, BuildID=20100717031100.

Reproducible: Always

Steps to Reproduce:
1. Unzip the attached testcase.
2. Open the file "index.html".
3. Try to pan the content of the iframe.
Actual Results:  
The content of the iframe can't be panned. The last visible number is 7 but the iframe content goes up to 33.

Expected Results:  
The content of the iframe can be panned until the last number 33 is shown.
(Reporter)

Comment 1

8 years ago
Created attachment 458074 [details]
Testcase
Regression from e10s changes, will be fixed by bug 571971.
Status: UNCONFIRMED → NEW
Depends on: 571971
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
WFM, but has no scrollbars : bug 627390
I'm able to reproduce this issue on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110623
Firefox/7.0a1 Fennec/7.0a1
Device: Motorola Droid 2
OS: Android 2.2

If I go to http://www.htmlcodetutorial.com/frames/_IFRAME.html the content of the iFRAME can not be panned.

Updated

7 years ago
tracking-fennec: --- → ?
Is this a regression?
Keywords: regressionwindow-wanted
http://www.htmlcodetutorial.com/frames/_IFRAME.html works for me
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
(In reply to comment #6)
> http://www.htmlcodetutorial.com/frames/_IFRAME.html works for me

It doesn't work for me on the latest Nightly build.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
(In reply to comment #6)
> http://www.htmlcodetutorial.com/frames/_IFRAME.html works for me

Does not work for me in landscape, does work for me in portrait; with the latest nightly
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I'm also unable to pan the iframe on that page in landscape.
Assignee: nobody → ben
Status: REOPENED → NEW
tracking-fennec: ? → +
It does work, but only if you will zoom in the page. Please see this video: http://www.youtube.com/user/qaioana#p/a/u/0/uJ53ZftBY5E
Assignee: ben → doug.turner

Updated

7 years ago
Assignee: doug.turner → nobody
Retest on native and move to native if it still applies.
Keywords: qawanted
Component: Panning/Zooming → General
Keywords: qawanted
Product: Fennec → Fennec Native
QA Contact: pan-zoom → general
I can pan the iframe on http://www.htmlcodetutorial.com/frames/_IFRAME.html with the latest nightly. Also while the page is fully zoomed out. Can you retest, please?
Status: NEW → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.