Archive folder location moves during account edit

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
8 years ago
6 years ago

People

(Reporter: cursus.publicus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; en-us) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16
Build Identifier: TB 3.1

Playing with account settings can reassert default Archive folder location.

I have removed my Archive folder and archive into the top level.

Playing with a test SMTP server reintroduced the default Archive folder.

Reproducible: Didn't try



Expected Results:  
Archive folder should not move unless the user moves it.

My Archive user pref is normally:

user_pref("mail.identity.id1.archive_folder", "mailbox://me%40this.that@mail.who.net");

My prefs.js file is hand edited and hence my mail folders ect are customised but this has worked well for a long time until now. I will attach an image showing my simplified layout - why does this have to be done after initial submission?
(Reporter)

Comment 1

8 years ago
Created attachment 458161 [details]
Customised mail folder layout
(Reporter)

Comment 2

8 years ago
I only use POP and 'SMTP'.

Playing with settings for a test SMTP server changed the Archive folder entry in my prefs.js to:

user_pref("mail.identity.id1.archive_folder", "mailbox://me%40this.that@mail.who.net/Archive");

I assume that no thought was given to somebody simply wanting to remove the extra level - see attachment. I would prefer to see this corrected so that I don't have to edit prefs.js after each account edit.

Comment 3

6 years ago
reporter, do you still see this problem when using a current version?
Component: General → Untriaged
Whiteboard: [closeme 2012-12-10]
(Reporter)

Comment 4

6 years ago
I have not been aware of it much since my move to SeaMonkey-PPC although I think I did have to correct it once immediately after the initial install.

I am afraid I can no longer comment on Thunderbird. I would not be concerned if this bug report were closed.

PPC users may wish to see: http://links.zero.eu.org/seamonkey/

Comment 5

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-12-10]
You need to log in before you can comment on or make changes to this bug.