libgklayout.so link failure because of undefined GLContext methods

RESOLVED FIXED in mozilla2.0b2

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mounir, Assigned: neil)

Tracking

Trunk
mozilla2.0b2
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 458365 [details]
Build log (libgklayout.so linking)

Since your today, m-c doesn't build because of undefined GLContext methods while trying to link libgklayout.so. I guess this come from one of these changesets: e235ebdbef50, e6b9c0f1c051, e235ebdbef50.

This seems to happen only for linux debug builds. At least, according to Olli (in CC), it doesn't happen for linux non-debug builds (I'm currently trying).
Mac fails too.
OS: Linux → All
(Reporter)

Comment 2

8 years ago
Created attachment 458392 [details]
mozconfig

In case of it depends of another option (very likely I guess).
I can reproduce the build errors with Mounir's mozconfig.

But I can't reproduce (I don't get any build error) with my own mozconfig:

ac_add_options --enable-application=browser
mk_add_options MOZ_CO_PROJECT=browser
ac_add_options --disable-optimize
ac_add_options --enable-debug
ac_add_options --enable-tests
Looks like this was caused by bug 571831, landed yesterday as:
  http://hg.mozilla.org/mozilla-central/rev/e6b9c0f1c051

I believe this only happens with
  ac_add_options --disable-libxul
Benoit, if you add that to your own mozconfig, it should reproduce the problem.
Blocks: 571831
Summary: libgklayout.so link failure because of undefined GLContext methods → libgklayout.so link failure in non-libxul builds because of undefined GLContext methods
FWIW I think the bustage is more likely:
http://hg.mozilla.org/mozilla-central/rev/23b8e7fd1794

Bug 575469 - afaict that was playing around with public/private functions.

More weirdness around this bustage is that debug shared builds are broken, but optimised non-debug builds work.
(In reply to comment #5)
> FWIW I think the bustage is more likely:
[...]
> Bug 575469

Ah, you're right.  I initially blamed bug 571831 because it was the most recent modification to WebGLContext.cpp (the file implicated in the warnings) and because it added uses of the "undefined" functions (e.g.  fDeleteRenderbuffers).  But it looks like bug 575469 did that too, and changed the declarations of all of those fFooBar functions, so that's much more likely to be the regressor.

/me updates 'blocks' field.
Blocks: 575469
No longer blocks: 571831
Summary: libgklayout.so link failure in non-libxul builds because of undefined GLContext methods → libgklayout.so link failure because of undefined GLContext methods
Indeed, the code that fails to link here seems to come from the first patch in bug 575469.

It's not incredible that it is sensitive to debug/nondebug since this code has some #ifdef DEBUG.
(Assignee)

Comment 8

8 years ago
Created attachment 458425 [details] [diff] [review]
Proposed patch
Assignee: vladimir → neil
Attachment #458425 - Flags: review?(vladimir)
Duplicate of this bug: 580061

Comment 10

8 years ago
My build was broken, so I took the liberty of landing this:

http://hg.mozilla.org/mozilla-central/rev/102fe68e84bf
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b2
You need to log in before you can comment on or make changes to this bug.