WebGL has broken non-libxul builds

RESOLVED DUPLICATE of bug 579931

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED DUPLICATE of bug 579931
8 years ago
8 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

8 years ago
Undefined symbols:
  "mozilla::gl::GLContext::CreatedTextures(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fGenTextures(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::DeletedRenderbuffers(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fDeleteRenderbuffers(int, unsigned int*)in WebGLContext.o
      mozilla::gl::GLContext::fDeleteRenderbuffers(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::CreatedProgram(mozilla::gl::GLContext*, unsigned int)", referenced from:
      mozilla::gl::GLContext::fCreateProgram()    in WebGLContextGL.o
  "mozilla::gl::GLContext::DeletedShader(mozilla::gl::GLContext*, unsigned int)", referenced from:
      mozilla::gl::GLContext::fDeleteShader(unsigned int)in WebGLContext.o
      mozilla::gl::GLContext::fDeleteShader(unsigned int)in WebGLContextGL.o
  "mozilla::gl::GLContext::CreatedFramebuffers(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fGenFramebuffers(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::DeletedProgram(mozilla::gl::GLContext*, unsigned int)", referenced from:
      mozilla::gl::GLContext::fDeleteProgram(unsigned int)in WebGLContext.o
      mozilla::gl::GLContext::fDeleteProgram(unsigned int)in WebGLContextGL.o
  "mozilla::gl::GLContext::CreatedRenderbuffers(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fGenRenderbuffers(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::DeletedTextures(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fDeleteTextures(int, unsigned int*)in WebGLContext.o
      mozilla::gl::GLContext::fDeleteTextures(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::DeletedFramebuffers(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fDeleteFramebuffers(int, unsigned int*)in WebGLContext.o
      mozilla::gl::GLContext::fDeleteFramebuffers(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::DeletedBuffers(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fDeleteBuffers(int, unsigned int*)in WebGLContext.o
      mozilla::gl::GLContext::fDeleteBuffers(int, unsigned int*)in WebGLContextGL.o
  "mozilla::gl::GLContext::CreatedShader(mozilla::gl::GLContext*, unsigned int)", referenced from:
      mozilla::gl::GLContext::fCreateShader(unsigned int)in WebGLContextGL.o
  "mozilla::gl::GLContext::CreatedBuffers(mozilla::gl::GLContext*, int, unsigned int*)", referenced from:
      mozilla::gl::GLContext::fGenBuffers(int, unsigned int*)in WebGLContextGL.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579931
You need to log in before you can comment on or make changes to this bug.