Closed Bug 58024 Opened 20 years ago Closed 18 years ago

Proxy/FTP: GIF image retrieved by FTP does not display

Categories

(Core :: Networking: HTTP, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: sgifford+mozilla-old, Assigned: mscott)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m18) Gecko/20001014
BuildID:    0000000000 (CVS 10/23/2000)

When I go to a particular ftp: URL that contains a GIF, the GIF is not
displayed, but instead just the text of the URL.

The image displays correctly in Netscape, and when I copy it to a Webserver.  I
don't have access to an anonymous FTP server, so I don't know if it's just this
image or any image.


Reproducible: Always
Steps to Reproduce:
1. Visit ftp://ftp.plex86.org/plex86bootslinux.gif


Actual Results:  The URL is displayed in the browser window

Expected Results:  The image being displayed.
this gif displays fine for me in 102508 mozilla trunk linux build.  It also
works in mac and win32 builds from today.
I'm still seeing it with a fresh build from this evening, but the bug goes away
if I am not going through my proxy.  The proxy interaction seems to go
correctly, from what tcpdump has to say, and Netscape 4.x is able to display the
image either with or without a proxy.

Do you have a proxy you can try this with to confirm?  If not, let me know and I
can probably give you access to the one that I'm using.
This is what Mozilla displays on its stdout/stderr when I try to load this page:

###!!! ASSERTION: nsHTTPChannel::SetTransferOffset: 'Not Reached', file
nsHTTPChannel.cpp, line 489
###!!! Break: at file nsHTTPChannel.cpp, line 489
###!!! ASSERTION: nsHTTPChannel::SetTransferCount: 'Not Reached', file
nsHTTPChannel.cpp, line 503
###!!! Break: at file nsHTTPChannel.cpp, line 503
PrefStyleSheet removed
Setting Preference Style Rules:
CreatePrefStyleSheet completed: error=0
 - Creating rules for link and visited colors
 - Creating rules for enabling link underlines
Preference Style Rules set: error=0
Enabling Quirk StyleSheet
Error loading URL ftp://ftp.plex86.org/plex86bootslinux.gif: 80510003
WARNING: not calling OnDataAvailable, file nsAsyncStreamListener.cpp, line 403

Does that error number mean anything to anybody?...
Based on the error number, this looks like it might be related to Bug #54559.
->networking.  
Assignee: asa → gagan
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
QA Contact: doronr → tever
->WorksForMe (Linux build 2000103009-MN6)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
->reopening... i didn't see the discussion about the FTP proxy.
I have only similarly verified that it is not a problem w/o a proxy.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
8051003 (if I am decoding it correctly) is NS_ERROR_REG_NOT_FOUND,
which doesn't ring any bells for me.  The equation I am using is out of
xpcom/base/nsError.h:

  nsresult = (1 << 31) | ((0x45 + MODULE_CODE) << 16) | (error),

where error=3 and MODULE_CODE=12.

This error code is generated in only a few places...
http://lxr.mozilla.org/seamonkey/search?string=NS_ERROR_REG_NOT_FOUND

Does anyone know of any free software for setting up a FTP proxy, or is
there one already setup on mozilla.org someplace for testing??
Squid is a free FTP proxy:

	http://www.squid-cache.org/
ftp bugs to component:ftp
Assignee: gagan → dougt
Status: REOPENED → NEW
Component: Networking → Networking: FTP
Target Milestone: --- → M19
Blocks: 61691
Blocks: 62354
It seems to be behaving correctly now when the image is there, but still behaves
incorrectly if the image doesn't exist, displaying the URL of the image instead
of a message about it being unavailable.  I have confirmed that the proxy is
returnin something reasonable (a text/html document describing the error).

This is in build 2000120608.
I see the problem with incorrect display if the FTP file doesn't exist both
using a proxy and not using a proxy.  This is different from what I saw
previously, where the bug only existed using a proxy.  This is on 2000122610.

This also happens with some GIF images over https. For example,
 <A HREF="https://www.nwolb.co.uk/nwol/images/nwblogo.gif">
https://www.nwolb.co.uk/nwol/images/nwblogo.gif</A>.

(Note that you need to disable TLS to talk to that site. Couldn't Mozilla do
that automatically on a per-site basis when necessary?)

It's happening for me with the 2001011118 build from
people.redhat.com/blizzard/.../RH7/mozilla-0.7-3.i386.rpm (on RH7 with 2.4 kernel)

The page title appears as 'GIF Image', as you'd expect, but it actually displays
the text of the URL instead of the image. If I save the GIF to a file and
subsequently point Mozilla at file:/home/dwmw2/nwblogo.gif I see it in its full
glory.

Mozilla doesn't say anything interesting when loading the image. Only:
Document https://www.nwolb.co.uk/nwol/images/nwblogo.gif loaded successfully

Scott, per email, I am assigning you my MIME related bugs.  
Assignee: dougt → mscott
FYI, still seeing this bug in 2001032614.
ftp proxies are really http
Component: Networking: FTP → Networking: HTTP
I no longer see this bug on Linux 0.9.7, with the image present or absent, over
FTP or HTTPS, and with my proxy turned on or off.  Since I don't know what
exatly fixed this, resolving as WORKSFORME.
Status: NEW → RESOLVED
Closed: 20 years ago18 years ago
Resolution: --- → WORKSFORME
qa to me.
VERIFIED: per reporter.
Without more info, hard to say if it is bug 70375, if the proxy returned a bad
header, the file, despite being called .gif, would not be treated as an image.

david: if you are still out there and have this problem... new bug, please.
Status: RESOLVED → VERIFIED
QA Contact: tever → benc
Summary: GIF image retrieved by FTP does not display → Proxy/FTP: GIF image retrieved by FTP does not display
You need to log in before you can comment on or make changes to this bug.