MailNews folder pane starts exteremely narrow

VERIFIED DUPLICATE of bug 54885

Status

SeaMonkey
MailNews: Message Display
P3
trivial
VERIFIED DUPLICATE of bug 54885
18 years ago
14 years ago

People

(Reporter: Scott Brodmerkle, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-SMP i686; en-US; m18) Gecko/20001024
BuildID:    2000102421

When loading MailNews, the folder pane starts in a very narrow state. None of
the names of the folders are visible. Thus the user immediately resizes the
thread pane, but alas, repaints do not occur on widening of the pane for some
odd reason. To get the window to paint properly, one must either collapse and
re-expand parts of the folder tree, or shrink and then re-expand the pane
vertically.

Reproducible: Always
Steps to Reproduce:
1. Start Mozilla.
2. Start MailNews with Tasks->Mail.


Actual Results:  (Almost) every time the folder pane starts out extremely narrow.

Expected Results:  IIRC, the folder pane used to remember it's previous size.


I'm using the three-pane mail view. I've seen this on both Classic and Modern.
I've also seen several other reports of this in netscape.public.mozilla.general;
apparently this is a problem on the Windows builds as well.

I suspect this is some type of regression, as I've only been seeing it for a
week or so now. Previously, it worked correctly.

Comment 1

18 years ago
I see this on NT4 (two machines) and on a Linux machine, essentially every
machine I have ever run Mozilla on.  However, I cannot ever remember a time when
the various folders remembered their previous size.

Comment 2

18 years ago
I started seing this after I switched to Classic skin. It doesn't matter that I 
switched back, they are still narrow. 

Comment 3

18 years ago
I have had the same problem (for about a month now?) - filed Bug 58063 before
I saw this one.  Configuration: Windows NT 4.0. 10/24 build.

Comment 4

18 years ago
*** Bug 58063 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
on linux, the "cure" is to resize the middle splitter so the folder pane is
maximum width. Then close mailnews. Restart. The splitter will then be in
"Normal" size. The alternative tree-pane stopped remembering size long ago btw,
not long after that feature was finally implemented. Filed bug 54885 about that.
(Reporter)

Comment 6

18 years ago
I confirmed that on Linux the "alternative" tree pane (folder and thread pane
splitting the top of the window with a full-width message pane below) is the
only one with this problem. So marking this as a dupe of 54885.

*** This bug has been marked as a duplicate of 54885 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified, this is a duplicate of bug 54885 "alternative mailnews 3-pane forgets
sizes."
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.