Closed Bug 580599 Opened 12 years ago Closed 11 years ago

Alt + Space bar in fullscreen mode, "Restore" makes no chrome window if previous window mode was maximized.

Categories

(Core :: Widget: Win32, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: alice0775, Assigned: jimm)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8pre) Gecko/20100714 Namoroka/3.6.8pre ID:20100714042159
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8pre) Gecko/20100714 Namoroka/3.6.8pre ID:20100714042159

In Firefox 3.6.x and Minefield 4.0b3pre,
Alt + Space bar in fullscreen mode, "Restore" makes no chrome window if previous window mode was maximized.

No title bar, no border of window.

This also happens on Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100721 Minefield/4.0b3pre ID:20100721041129.

However, This not happens on Firefox 3.5.x.
Because the "Restore" menu is disabled on Mozilla/5.0 (Windows; U; Windows NT 6.1; ja-JP; rv:1.9.1.12pre) Gecko/20100712 Firefox/3.5.12pre ID:20100712034415

Reproducible: Always

Steps to Reproduce:
1. Start Browser with new profile
2. Make window maximized.
3. Press F11 (into full screen mode)
4. Press Alt + Space

Actual Results:
 The browser become no-chrome window(no title, no border)

Expected Results:
 The browser should be previous normal mode

FYI, In Firefox 3.5, Chrome and IE8, The "Restore" menu item is disabled in fullscreen mode.

I think that the "Restore" menu item should be disabled for Firefox like other browsers.
Regression window:
Works(The "Restore" menu item is disabled):
http://hg.mozilla.org/mozilla-central/rev/845fd6b1ef23
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090708 Namoroka/3.6a1pre ID:20090708042452

Fails(no chrome window):
http://hg.mozilla.org/mozilla-central/rev/0d2fc193cd1f
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090709 Namoroka/3.6a1pre ID:20090709091211

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=845fd6b1ef23&tochange=0d2fc193cd1f
Reverted to b7d5a56b44e7 in local build, then the problem was gone.
Landing of the patch of Bug 484488 caused the problem.
Blocks: 484488
Keywords: regression
That is one nifty trick!
Depends on: 575195
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580564
(In reply to comment #4)
> 
> *** This bug has been marked as a duplicate of bug 580564 ***

is it same regression range?
I can not reproduced the Bug 580564.

So i reopen this.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
blocking2.0: --- → ?
blocking2.0: ? → final+
Assignee: nobody → jmathies
(In reply to comment #2)
> Reverted to b7d5a56b44e7 in local build, then the problem was gone.
> Landing of the patch of Bug 484488 caused the problem.

Seeing as how we no longer actively support ce, lets try backing this out as a fix for 4.0.
(In reply to comment #6)
> (In reply to comment #2)
> > Reverted to b7d5a56b44e7 in local build, then the problem was gone.
> > Landing of the patch of Bug 484488 caused the problem.
> 
> Seeing as how we no longer actively support ce, lets try backing this out as a
> fix for 4.0.

Actually, there are a lot of changes there. I think I'll try to fix this locally in widget.
Duplicate of this bug: 592384
Attached patch fix v.1Splinter Review
This traps the appropriate sys command event and displays the menu correctly.

Down the road we can leverage these changes to customize the system menu. For example it might be nice to add an "exit full screen" option.
Attachment #485320 - Flags: review?(neil)
Blocks: 606520
Comment on attachment 485320 [details] [diff] [review]
fix v.1

[There's one other little edge case... if you have another window open with a full screen window in the background, you can right-click the taskbar button for that window and obtain a system menu that the app has no control over... what IE does in that case is to turn of the WS_MAXIMIZEBOX style in full-screen mode which disables the Restore/Maximize menuitems... while they subsequently ignore move they oddly switch out of full screen when they abort the move.]
Attachment #485320 - Flags: review?(neil) → review+
Comment on attachment 485320 [details] [diff] [review]
fix v.1

>+#define MOZ_SYSCONTEXT_X_POS              20
Actually the X pos seems to be 0 normally.
(In reply to comment #10)
> Comment on attachment 485320 [details] [diff] [review]
> fix v.1
> 
> [There's one other little edge case... if you have another window open with a
> full screen window in the background, you can right-click the taskbar button
> for that window and obtain a system menu that the app has no control over...
> what IE does in that case is to turn of the WS_MAXIMIZEBOX style in full-screen
> mode which disables the Restore/Maximize menuitems... while they subsequently
> ignore move they oddly switch out of full screen when they abort the move.]

I'll file a follow up. That's gotta be xp/vista only since in win7 this brings up the app's jump list.
(In reply to comment #11)
> Comment on attachment 485320 [details] [diff] [review]
> fix v.1
> 
> >+#define MOZ_SYSCONTEXT_X_POS              20
> Actually the X pos seems to be 0 normally.

I noticed that. 20x20 seemed better. We can tweak that easily if people have a major issue with it.
http://hg.mozilla.org/mozilla-central/rev/a361ff268224
Status: REOPENED → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → FIXED
Blocks: 606610
You need to log in before you can comment on or make changes to this bug.