Closed Bug 580893 Opened 9 years ago Closed 9 years ago

Wrong display of buttons in the survey page with long labels

Categories

(Mozilla Labs Graveyard :: Test Pilot, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: flod, Unassigned)

Details

(Whiteboard: ui, l10n)

Attachments

(4 files, 1 obsolete file)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

When labels used for these buttons are too long, the character » is displayed on the left of the button glyph.

I need to check this also on other platforms to see if it's only a Mac problem.
Ever worst on Windows XP
Flod: Which version of test pilot are you using?
(In reply to comment #2)
> Flod: Which version of test pilot are you using?

Version 1.0 (built-in in b2)
Flags: in-testsuite?
Flags: in-litmus?
Priority: -- → P1
Target Milestone: -- → 1.3
Attached patch proposed patch (obsolete) — Splinter Review
I'm using width 310px, but it still can be a bit longer if needed.
(In reply to comment #4)
> I'm using width 310px, but it still can be a bit longer if needed.

How can we test it?
Andres: I'm concerned that any width we hard-code into the page layout will be too wide for some languages, too narrow for others.  Can we instead allow the width to be determined dynamically based on the width of the contents?

Thanks.
Flod:  To test this (or any patch), you'll have to be running Test Pilot from an Hg checkout (instructions here: https://wiki.mozilla.org/Labs/Test_Pilot/debug ) Then save the proposed patch as a "patch.diff" file, and do

hg import patch.diff

you may have to enter an Hg commit comment; just enter whatever.  Then restart Firefox and you should see the changes applied.
Attached patch proposed patch 2Splinter Review
Removed the width value, the box now grow according to the label width.
Attachment #462480 - Attachment is obsolete: true
This is the kind of thing (odd layout) QA just knows to look out for during manual testing.  Not going to write a specific litmus test cases for it. Probably not easily automated either.
Flags: in-testsuite?
Flags: in-testsuite-
Flags: in-litmus?
Flags: in-litmus-
Whiteboard: [4b2] → UI
Target Milestone: 1.3 → 1.7
Whiteboard: UI → ui, l10n
Target Milestone: 1.7 → 1.1
OS: Mac OS X → All
Hardware: x86 → All
Applied Andres' patch in http://hg.mozilla.org/labs/testpilot/rev/ff3a940ce3cd and verified that it works as intended.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified with recent build of TP
Status: RESOLVED → VERIFIED
This patch fixes this bug as well as bug 594164.
Attachment #500435 - Flags: review?(dtownsend)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attachment #500435 - Flags: review?(dtownsend) → review+
Landed in mozilla-central: http://hg.mozilla.org/mozilla-central/rev/edf04cd3cca0
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.