Closed Bug 581041 Opened 10 years ago Closed 10 years ago

Tab contents temporarily displayed incorrectly when switching tabs

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 555904

People

(Reporter: mark, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

I've been seeing an ongoing issue since Firefox 3.6 came out.  When switching tabs, sometimes the page contents displayed will actually belong to the next tab over.  For example, if I have tabs ABCD open with A active, then click on B, the page contents for C may show for a couple seconds before reverting to the page contents for B.  Or, sometimes the newly selected tab may show as a blank panel for a couple seconds before the proper contents are displayed.  

Reproducible: Sometimes

Steps to Reproduce:
1. Visit any site, pop open several tabs in the background
2. Click on another tab to select it 
3. The tab _may_ display its contents incorrectly

I know this isn't very specific, but I see it consistently/infrequently (maybe 5-10% of the time).
Actual Results:  
The tab contents are displayed incorrectly (the contents for the next tab over are displayed for 2-3 seconds before reverting to the proper tab's contents, or a blank panel is displayed before reverting to the proper tab's contents).

Expected Results:  
The selected tab's contents would be displayed immediately.

I've seen this with FX 3.6.* and 4.0b1, on both WinXP and Win7 (work and home).  I first noticed this shortly after the release of FX 3.6, and I'm pretty sure I never saw it before that.
After encountering this another couple times today, it appears that it's happening after I close the active tab by middle-clicking it, rather than after left-clicking to change the tab.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555904
You need to log in before you can comment on or make changes to this bug.