Closing tab flips to next-next tab before reverting to next tab

RESOLVED FIXED in Firefox 4.0b3

Status

()

defect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: djc, Assigned: dao)

Tracking

({regression})

3.5 Branch
Firefox 4.0b3
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+, status1.9.2 wontfix, status1.9.1 wontfix)

Details

Attachments

(2 attachments)

I've seen this both on Windows and OS X, most recently with Firefox 3.6.2. When I have multiple tabs open, if I close a tab, the content window switches to a tab that's to the right of the "next" tab (the one to the right of the one I just closed) real quick, before reverting to the correct one.

So with tabs 1, 2, 3, when I close 1, 3 briefly flashes, then 2 shows up.
Can you reproduce this in safe mode?
I'm now running Fx in safe mode on my work box, I think I saw it once. Problem is, I don't really have a way to reproduce it, although it happens a few times a day.
This definitely still happens in safe mode, on Windows XP.
So do you have steps to reproduce?
No... Do we have a way of tracing/saving open tabs, so that I might be able to look up a specific sequence of tab operations when I see it happening again?
- Start in safe mode (Start/Run, firefox -safe-mode)
- Open the following URLs, in order (I used Ctrl+T, paste into address bar, Enter):

http://adam.blog.heroku.com/past/2010/3/30/urls_are_the_uniform_way_to_locate_resources/
http://news.ycombinator.com/item?id=1230156
http://techcrunch.com/2010/03/30/unvarnished-a-clean-well-lighted-place-for-defamation/

- Focus on first tab, close (I used Ctrl+W)

When doing this, I get to see the TechCrunch tab for a few tenths of a second before I get to the news.ycombinator.com tab.
I'm seeing this same issue in Fx v3.6.3 on Windows 7.  Closing a tab, when multiple tabs are loaded, occasionally shows next-next tab before jumping back to next tab.  It doesn't matter what tabs are open, just that there are several loaded.  Happens in safe mode too.
I've noticed that this bug appears much more frequently when I've got a lot of tabs with pages loaded from wired.com.
Duplicate of this bug: 581041
Duplicate of this bug: 562336
As per Bug 562336, This is regression of Bug 462673
Blocks: 462673
Keywords: regression
Posted patch patchSplinter Review
This is great stuff. It took me a while to figure out what's going on and what to do about it.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #460372 - Flags: review?(gavin.sharp)
Version: 3.6 Branch → 3.5 Branch
blocking2.0: --- → ?
status1.9.1: --- → ?
status1.9.2: --- → ?
Attachment #460372 - Flags: review?(mano)
Attachment #460372 - Flags: review?(gavin.sharp) → approval2.0?
blocking2.0: ? → betaN+
Attachment #460372 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/26dc2e508587
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b3
Posted patch 1.9.2 patchSplinter Review
Attachment #461483 - Flags: approval1.9.2.9?
Duplicate of this bug: 562336
This appears to be a minor polish bug that we wouldn't want to take on the stable branches (beyond the inevitable .1/.2 "cleanup" releases). Is there more going on here than a minor visual glitch that resolves itself?
Attachment #461483 - Flags: approval1.9.2.9? → approval1.9.2.9-
No, that's all that's going on. IMO just fixing it 2.0.x is fine.
Duplicate of this bug: 605122
Flags: in-testsuite?
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.